Question No idea how I'm crashing (PLEASE HELP)

Jan 4, 2021
1
0
10
0
Hello I have built my PC not too long ago maybe mid-december and am now receiving some problems with my games. I have been starting to crash randomly with frequent bluescreens. I have tried DDU'ing to older drivers but that just made the problem happen in select games and it doesn't crash anymore on GTA V like it did the first time I had the latest drivers. I do not know how I got this problem, I have only started to get this problem when I installed my SATA SSD and do not know why it fixes the problem when I take out the SATA but the problem still happens when my game is on a different drive. Can someone please tell me how I should go on from here. I exceed Recommended Requirements and am also getting good temps.
SPECS:
AMD Ryzen 5 2600X
ASROCK PRO4 B450M
GTX 1660ti OC GIGABYTE
750W MWE GOLD PSU COOLER MASTER
16GB 3200mhz CORSAIR
250GB A2000 KINGSTON M.2
480GB SATA SSD KINGSTON

DRIVERS I INSTALLED AFTER CLEAN WIPE / Reinstall OS:
GEFORCE Experience, AMD Chipset Drivers from ASROCK website, Realtek LAN, Realtek Audio.

If you need any more info please ask me.
 
Hello I have built my PC not too long ago maybe mid-december and am now receiving some problems with my games. I have been starting to crash randomly with frequent bluescreens. I have tried DDU'ing to older drivers but that just made the problem happen in select games and it doesn't crash anymore on GTA V like it did the first time I had the latest drivers. I do not know how I got this problem, I have only started to get this problem when I installed my SATA SSD and do not know why it fixes the problem when I take out the SATA but the problem still happens when my game is on a different drive. Can someone please tell me how I should go on from here. I exceed Recommended Requirements and am also getting good temps.
SPECS:
AMD Ryzen 5 2600X
ASROCK PRO4 B450M
GTX 1660ti OC GIGABYTE
750W MWE GOLD PSU COOLER MASTER
16GB 3200mhz CORSAIR
250GB A2000 KINGSTON M.2
480GB SATA SSD KINGSTON

DRIVERS I INSTALLED AFTER CLEAN WIPE / Reinstall OS:
GEFORCE Experience, AMD Chipset Drivers from ASROCK website, Realtek LAN, Realtek Audio.

If you need any more info please ask me.
You can set the memory speed to 2933Mhz in the bios and see if that fixes the crashing.
 

ASK THE COMMUNITY

TRENDING THREADS