[SOLVED] No internet after clicking “network reset”


Jun 20, 2019
Today I tried to launch the Rockstar Games launcher but it was in offline mode. Then someone told me to click the network reset button in settings. I clicked it and after restarting I did not have Internet connection. In device manager it’s saying “windows is still setting up the class configuration for this device (code 56)”.
I spoke to Microsoft support and they told me to write a bunch of commands in CMD, Reinstall the drivers, and click the Network Reset button again. Neither of them worked. I tried reinstalling the drivers from both Realtek’s site and motherboard’s site but none of them worked. I tried using my iPhone for Internet but it had the same error (code 56 ).

I also tried uninstalling the driver but it reinstalls again instantly.

I had Internet before clicking the button and I have it right now on my phone so it isn’t a wi-Fi problem.

Motherboard: Aorus B450 Elite
CPU: Ryzen 7 2700x
GPU: GTX 1060 6GB
RAM: 2x8GB G.Skill DDR4 3200MHz