[No longer relevant] Desktop computer won't boot past initial logo screen ?

Status
Not open for further replies.

meowmeow1234

Prominent
Sep 22, 2020
5
0
510
0
The short story is that my Windows 10 computer which was working fine a few hours ago now won't boot up past the initial CyberpowerPC logo screen. My motherboard is ASRock B450M Gaming. I have tried to get into BIOS by holding F8 or F11 during startup, but it doesn't work. I have disconnected all devices aside from a monitor and a keyboard. I have even disconnected the hard drive. I have also removed all but one piece of RAM.

(Edit: Apologies but I have discovered that I had something else connected, which was an SSD I believe? I have disconnected that and now it has automatically booted into the BIOS. I will try to figure out what's going on now but it seems like the SSD is the issue. Again sorry for overlooking this)

The longer story is that when I woke up today my computer had apparently restarted and was at a "Reboot and select proper boot device" screen. I rebooted and it started up normally. Hours later, I got an error out of nowhere that said "Unknown Hard Error" I believe. Minutes later I got a BSOD with the stop code "Critical Process Died". After rebooting things seemed okay, until about 10 minutes later when I got another BSOD with the same stop code. I tried to start up again to do a suggested sfc scannow, but before windows could fully start up, it crashed again. And then after that, further attempts to start up would not get past the initial logo.

I am out of ideas about what to do now. Should I take it to a repair shop? Any help would be greatly appreciated.

Also I will mention that this computer was a fully pre-built one I ordered from newegg about a year ago. I have not tinkered with it at all, aside from removing one piece of RAM from it many months ago because it was apparently causing crashes. I'm not very hardware-savvy so I haven't done anything else with it - everything is pretty much exactly as it was when it arrived.
 
Last edited:
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS