Question No monitor/ mouse/ keyboard activity

jbrannan

Distinguished
Dec 2, 2008
59
0
18,630
0
Hello,

My PC is about 5 years old, and was previously working fine. I haven't used it for a few months as it was being transported from Turkey to the UK.

Now, when I turn it on, my monitor goes into power saving mode straight away. My keyboard and mouse (USB driven) don't light up. I noticed the fans on my GPU also stop spinning after maybe 20-30 seconds. There are no beeps and, as nothing seems to work, I can't enter UEFI/ BIOS.

I've tried two different monitors with the same result, so I guess my monitor isn't the issue.

I thought something might have been unseated in transit, so I've reseated the GPU, SSDs/HDDs and RAM (trying one stick at a time). I've tried taking out and replacing the CMOS battery.

I wondered whether the power cables could be an issue, moving from European plugs to UK plugs. I only have one UK power cable at the moment, but whether it is used for the PC or the monitor doesn't seem to make a difference.

I don't have a spare PSU to try, and don't really feel confident breadboarding the system...

Any advice would be really appreciated!

Thanks!
Raeh
 

Lutfij

Titan
Moderator
Can you please parse the specs to your build like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:

Perhaps try and work without a discrete GPU if your processor has an iGPU and the motherboard has display output ports.

I don't have a spare PSU to try, and don't really feel confident breadboarding the system...
Part of troubleshooting is to go through a process of elimination, meaning you're going to have to tear down the build and work with one component at a time, including a spare PSU that's reliably built.
 

jbrannan

Distinguished
Dec 2, 2008
59
0
18,630
0
CPU: AMD Ryzen 5 1600X 3.6 GHz 6-Core Processor/ Deepcool GAMMAXX 400 74.34 CFM CPU Cooler
Motherboard: Asus PRIME B350M-A Micro ATX AM4 Motherboard
Ram: Corsair Vengeance LED 16 GB (2 x 8 GB) DDR4-3200 CL16 Memory
SSD/HDD: Western Digital Caviar Blue 1 TB 3.5" 7200 RPM Internal Hard Drive/ Toshiba Q300 480 GB 2.5" Solid State Drive (and a couple of older ones)
GPU: EVGA SC GAMING ACX 3.0 Black Edition GeForce GTX 1070 8 GB Video Card
PSU: Corsair CX650M 650 W 80+ Bronze Certified Semi-modular ATX Power Supply
Chassis: Deepcool Dukase ATX Mid Tower Case
OS: Windows 10
Monitor: Dell S2716DG (and an old Samsung I tried)

I take your point about having to try the different components, but I don't have the parts or experience to breadboard/ swap everything out. Still, I was hoping to do whatever I'm capable of doing by myself first, then maybe have to pay someone if I can't sort it.
 

ASK THE COMMUNITY

TRENDING THREADS