[SOLVED] No monitor signal, no keyboard connection, new prebuilt

Dec 11, 2021
2
0
10
0
Hello, I have bought the VENGEANCE i7200 Gaming PC, i9-10850K, RTX 3080, 1TB M.2, 2TB HDD, 32GB DDR4-3200

It is a prebuilt pc from corsair which I bought for the same prise over a trusted seller on eBay.

It came here, today my monitor came so I plugged everything in. No signal with the displayport though, I tried everything. Restarting, resetting, hdmi, (have heard many people have the same problem even with cleaning RAM) can't believe I would need to clean ram or so since it's new bought prebuilt and tested.

https://www.ebay.com/itm/CORSAIR-VENGEANCE-i7200-Gaming-Desktop-i9-10850K-32GB-2TB-HDD-1TB-SSD-RTX-3080-/324780991903?mkcid=16&mkevt=1&_trksid=p2349624.m46890.l49286&mkrid=711-127632-2357-0

I have bought the LG 27GL850 from Newegg, so I also tried different versions of dp. Nothing works. THEN, I realized something... my rgb mouse pad, and keyboard WONT light up even though it's plugged into my computer which is on, by the way fans and rgb are also on inside the pc.

I heard many people having the exact problem as me even though changing ps, cleaning RAM and everything, and why should I do this with an prebuilt computer by corsair?! It's clean!

I thought about using a different dp cable, but it can't be cause of that right? Because the lights of the keyboard also won't light up...


 
Last edited:
Dec 11, 2021
2
0
10
0
Do not touch the interior of your prebuilt or you may void your Warranty.

I see it is a refurbished/Second hand unit, so anything could have happened to it prior.
Do you have in fact a return policy or Warranty with the seller?
I am not sure, I provided the link above where I bought it from
 
Last edited:

ASK THE COMMUNITY