No mouse or kybd after W1o upgrade

sargan

Honorable
Jul 4, 2012
183
0
10,690
1
Running W7 on a modern desktop (Asus mobo)

I had put this off for a long time - hoping it would be stable by time I upgrade.

Followed full update process - al up todate before upgrade.
After 100% upgrade ... it rebooted and got to to login screen - would not accept any mouse of keyboard input (both are USB)
Reboot and at BIOS level the mouse & kybd work fine.
As soon as I boot up OS they don't work ....

I then tried a (very old) PS2 kybd ... that did work and allow me to login ... but mouse still not working.
Mouse does power up (LED) but no cursor on screen.

A number of popup windows telling me I need to update ... but can't proceed as no mouse.
I have an old PS2 mouse but PC only has 1 PS2 port .... if I plug in mouse into it ... there is a beep but still no cursor.

It looks like all files are there - it has network access ... just can't get any USB devices to work

Help - please - need to resolve ASAP
 
Hi

This problem occurs more with laptops than desktops and is usually interference between keyboard and mouse drivers

I would use ps/2 mouse and no keyboard
Use the on screen keyboard
( you dont need a touch screen for this to work)

Google loging into windows using on screen keyboard

Windows update may fix the problem or you may need to download the motherboard chipset drivers or update the keyboard and mouse drivers or remove them to fix these problems

I presume you were using usb 2 ports not usb 3 ports for keyboard and mouse

Let us know how you get on

Regards
Mike Barnes
 

sargan

Honorable
Jul 4, 2012
183
0
10,690
1
No idea how to use W10 as this was first upgrade. So unaware of on-screen keyboard

I managed to find my way to device manager and it shows no entry for a mouse ... and yellow warning triangle against all USB drivers.
yet if I go to the driver and use >update driver > search .. it tells me latest driver installed.

I am going to chicken out and roll back .... and look at drivers, before I try again.
 

sargan

Honorable
Jul 4, 2012
183
0
10,690
1
I have rolled back as have to have PC working tomorrow.

Anyway ......... issue update..

I managed to find my way to device manager using Keyboard ... and found there were yellow warning triangles against all the USB controller entries.
For each I went in and read the message "Software for device has been blocked, contact vendor for new driver"
I tried update driver software> search automatically it comes back with "Windows has determined the driver software for your device is up to date"

So Windows tells me it needs me driver and driver is up to date - I just knew this W10 upgrade would fail.

I chickened out and rolled back to W7 ... at least all is working again ...

I'll have to try a search around ASUS web site see if there are alternative drivers.
 

sargan

Honorable
Jul 4, 2012
183
0
10,690
1
I have all the latest W7 drivers installed .. there are updates for W1o .. but I can't install now ... and I can't install; after upgrade if no mouse/keyboard working.
 

sargan

Honorable
Jul 4, 2012
183
0
10,690
1
Anybody got any clue here ?

ASUS advise no newer USB driver - in fact they aren't even producing one for W10.

ASUS do advise that there are new drivers for:

# Chipset - Intel Chipset driver

# Chipset - Management Engine interface

but these are W10 specific and can't be used on W7 (chicken & egg situation)
 

ASK THE COMMUNITY