Question "No NVME Device Detected" - Gigabyte X570 Gaming X Rev 1.1

Jaramin

Honorable
Jan 6, 2015
2
0
10,510
0
Hey Everyone,

So I am going to give a bit of the history of the issues I was with my system having before getting to what my issue is right now, just in case any of it is helpful.

My original system was this:

OS: Windows 10 Pro
CPU: Ryzen 3600
Mobo: MSI B450 Tomahawk
GPU: Gigabyte GTX 1070 8 GB
Boot Device: 1 TB ADATA XPG 8200PNP SSD
Memory: Ballistix Sport LT 32GB (2 x 16GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600)
PSU: EVGA Supernova 850W G3

So I built this system in the Summer of 2019, flashed the Mobo to accommodate the Ryzen 3 CPU and everything seemed fine. No issues for quite some time.

Around March I started getting occasional IRQL and Kernel exception BSODs, but nothing too bad - maybe once a week at most. By late April/May, I was having BSOD errors once a day or more. I got so sick of it I went and updated every bit of firmware I could, and updated the BIOS to the most recent available from MSI. When I updated the BIOS though, I could no longer boot to my NVME drive at all, it would immediately BSOD with the same errors as above. I decided to roll back to an earlier BIOS version (but still more updated than my original version) and it fixed the problem - everything was fine again and my system was stable until July.

I went downstairs for lunch one day, came back upstairs and my system would no longer POST. The VGA troubleshooting LED would illuminate almost immediately after powering up and no image would appear. I tested the GPU in another computer and it was fine, I also tested another GPU in my system and the same error occurred. I tested the PSU both independently and in another machine, and it was fine. I tested another PSU in my machine, same issue. I tried every possible configuration of RAM with my original sticks, and tried DDR4 sticks from another PC, same issue. I breadboxed the build, reseated the CPU, disconnected all other drives, and the issue remained so I figured the Mobo was bad and RMAd it. I got it back about two weeks later, but there was no indication from MSI that they had done anything except updated the BIOS.

When I got it back, I left it powered on and just left it for awhile - after about 10 minutes it automatically popped into BIOS - but the VGA error LED would still come on the entire time before doing so. The board no longer recognized my NVME drive ( I couldn't get into BIOS before the RMA so I don't know if this issue was present then or only after the RMA), and no amount of messing with changing PCIE configurations or disabling CSM did anything at all. I decided to cut my losses and get a new board since this one was taking 10 minutes to even get into BIOS anyway, I figured something was still wrong with it.

I got a new Mobo, a Gigabtye X570 Gaming X (the system is otherwise identical to the above).

The new board has no issues getting into BIOS, no apparently VGA issues, but also does not recognize my boot NVME drive. When it is plugged in, it does get hot. I have tried both slots on the board, and again every BIOS and hardware configuration I can think of to get the Mobo to find the drive. CSM off, Safe Boot off, PCIE configs, even through a Windows 10 installation Media USB, the drive will not show up. I tried to reinstall Windows to another drive to see if I could see the drive via some utility in the OS, but I can't even reinstall. I got the same BSODs as I mentioned above whenever the installation portion of the setup starts (using both a Windows Media created flashdrive, and a UEFI bootable drive made in Rufus.)

At this point I'm pretty frustrated at the entire situation. Did I get struck by lightning or is there something I'm missing here? The only components I can't really test independently are the CPU and NVME drive as I don't have another machine handy which can utilize them. But I'm not sure if the CPU is even able to cause the sort of issues I'm having? I suspect that the NVME drive is toast or has a corrupt controller, and I am ready to RMA with ADATA for the SSD, but I don't want to just RMA everything while overlooking something stupid and easy to fix. I also wasn't as diligent with backups as I should have been, so I'm worried about losing some important personal data on the NVME drive, but I guess at this point I may have no choice but to roll the dice there.

Thanks for your time reading this, and please let me know if there's anything you guys can think of for me to try.
 

ASK THE COMMUNITY

TRENDING THREADS