Question No post after putting bios flashed rx5700 into new system

Jan 6, 2021
1
0
10
0
I just build a new system with my old rx 5700 i previously flashed to an xt version and now my new system won't post.

My setup:
cpu: i5 10400f cooled by a corsair h100x
gpu: asus blower style rx5700 (flashed to xt)
motherboard: asrock b460m itx/ac
ram: vengeance pro 16gb 2666mhz
psu: corsair cx550f

all rgb and fans powered by the motherboard works which lead me to believe that the psu and motherboard is not the issue. i then looked for broken pins in the socket and there was nothing.
when powered on the gpu's fan rambs up and down and continues to do so, also when starting the whole system it shuts down and restarts. And the speaker thing does not beep at all.
I have tried: reseatting everything but the psu and i have tested all display outputs on the gpu. I have also checked if it was my monitor with a hdmi to my laptop.

if it turns out the gpu is actually dead, can i still get my warranty even after flashing the bios to an xt?

any suggestions?
 

Viking2121

Distinguished
I'm not entirely sure how to flash a AMD card back to factory anymore, I haven't done a bios flash to a GPU since the HD5850 days.

I do know you can bring the card back, its not dead but you will need to use another GPU to do it, I think you can use the onboard video from that 10400f to do it. I hope someone with more experience than I stops by.
 

ASK THE COMMUNITY