Question No POST and No beeps

Sep 3, 2020
12
0
10
0
My computer won't boot, no POST and no beep. The power supply popped and cannot be used so I removed it and put a new one and it worked but the next year i tried to power it on, it won't boot. I don't know what the problem is but i guessing that it could be the motherboard. The fans are spinning very quickly from the cpu fan and the system fan. Please help me...

Parts:
LGA 775 Motherboard from Lenovo
Intel Pentium E7500
500GB of Hard Drive
4GB of DDR3 Ram
450 Watts power supply from Enermax.
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Model for your Enermax PSU? Areyou sure your motherboard has all power inputs plugged in...i.e, that the PSU you have has the necessary connectors for the motherboard?
 

dimtodim

Respectable
Sep 4, 2018
654
61
1,990
14
My computer won't boot, no POST and no beep. The power supply popped and cannot be used so I removed it and put a new one and it worked but the next year i tried to power it on, it won't boot. I don't know what the problem is but i guessing that it could be the motherboard. The fans are spinning very quickly from the cpu fan and the system fan. Please help me...

Parts:
LGA 775 Motherboard from Lenovo
Intel Pentium E7500
500GB of Hard Drive
4GB of DDR3 Ram
450 Watts power supply from Enermax.
probably isnt problem with motherboard...if motherboard die fans not working...maybe u have problems with other components...did u check ram?
 

ASK THE COMMUNITY

TRENDING THREADS