Question No POST, DRAM_LED stays yellow.

prateek320i

Commendable
Nov 24, 2017
33
0
1,560
9
Hi all,

My key components are like this-
i7 8700k
Asus ROG Strix Z370 E gaming
G-Skill Ripjaws 3200 MHz 8GBx2
Corsair HX750 PSU
Corsair H110i v2
Gigabyte GeForce 1080 Ti OC edition
Samsung 850EVO 250 GB with 2 additional drives.

Few days ago, this happened. My PC was working fine, I played a lot of games that day. Then I logged off my custom built PC, turned if off, and opened my case to remove GPU (to clear the dust off).
Then I thought to plug my display through MOBO’s inbuilt display port. The PC now behaved abnormal.
Fans were running as usual, CORSAIR logo on H110i was lit but there was no welcome screen, no display at all.
I turned off the mains, re booted it, took a close look and found that DRAM_LED was turning yellow for 4–5 seconds and then turned off. Firstly, the CPU_LED turns RED then turns off quickly, then DRAM_LED stays yellow.


Then I removed all the component and this time booted only with these components connected- Processor, RAM, display.
It showed the same result. No display, DRAM_LED stays yellow for 4-5 seconds.
I checked all the slot A1 A2 B1 B2 individually, still getting same. (I seated the RAM properly).
I also did reset CMOS, nothing happened.
When I booted without RAM, DRAM_LED stayed yellow forever.

I have no idea what went wrong suddenly.
Please help, I can’t play FIFA
 

prateek320i

Commendable
Nov 24, 2017
33
0
1,560
9
if ram led dissapears, then u dont have ram issue
could be just bios struggles with finding out video output
it could be cable (either broken pin detect or not fully plugged in)
u can also tr to reset CMOS, refer to your mainboard manual
Thanks for the quick reply. I changed display cable, and tried reseting CMOS, both didn’t help.
This time I notice that the DRAM_LED stays yellow forever, in both cases
i) without DISPLAY, MOUSE, KEYBOARD
ii) with display, mouse, keyboard
 

ASK THE COMMUNITY

TRENDING THREADS