Question No POST on custom built PC after doing some minor maintenance


Dec 15, 2016
I have a custom-built PC. I am not new to building PC's I just have a problem that i cannot seem to solve by myself.
The problem has to be user induced but I cannot trace it down.
It started when I decided I wanted to add 2 more HDDs to my setup. I have a custom water-cooling loop that cools the CPU and 2 GPUs in SLI. Therefor it was impossible to connect new sata cables to the MB without removing a lot of water lines and the 2 GPUs. As the space is quite tight I did have trouble getting the GPU's off the PCI-E connection. but all went relatively smoothly. After all was said and done and my new drives were installed I ran into the issue. The MB gets power indicated by a green LED on the southbridge. then changes to a quick 2 flash of blue and continues into a slow blue fade in and out. When I press the power button nothing happens.

I have checked the power button connections. (all good). I have even tried a screwdriver to cross the pins. I tried without the new drives. I tried one GPU at a time in different PCI-e slots. I have checked every connection to the MB from the PSU. I tried a known good GPU from my other PC. I've examined the MB for damage where i might possibly have allowed a tool to touch it.

No water has gotten on anything when I removed the water lines either. I made sure of that when taking out the GPUs.

Yes the PC was working excellent before I all of this

So my questions are... What causes a no post with no attempt to post typically(no fans come on, no LEDs change or turn on. Simply dead other than the breathing Blue LED)? Anything I should try to narrow down the possibilities? Is that a normal ASRock Taichi LED sequence as I described above?

ASRock Taichi x370 AM4
x2 Nvidia Asus Poseidon 1080 TI GPUs
Ryzen 1700x
32 GB corsair vengeance ddr4 ram
XFX platinum 1000w PSU
m.2 1tb SSD
lots of other HDDs/SSDs... on SATA
Last edited:



Latest posts