Question No post / video output

QwerkyPengwen

Dignified
Herald
So just a couple days ago I was having this issue and CMOS reset fixed it.

But just yesterday I turned it off and now it turns on but won't post.

Things I've tried:

CMOS reset
Different working PSU
Bread boarding
Trying each RAM stick individually in all slots
Unplugging all storage devices while breadboarded and after CMOS reset.

My entire hardware list is in my signature.

If there's anything I might be missing for troubleshooting steps let me know otherwise I'll be wasting my day going to a computer shop to get further testing done on motherboard, CPU, and RAM (since I don't have spares of these to test myself)

Thanks in advance.
 

QwerkyPengwen

Dignified
Herald
so I took it to the computer shop.
they apparently need to hold onto it for up to 24 hours to do the extra troublshooting that I couldn't do on my own.
So I'll know by tomorrow what the deal is.

I am so hoping they don't eff up my system with someone who is incompetent.

I am also hoping that it is simply a case of dead RAM and nothing else cuz that would be the cheapest thing to replace.

Otherwise, I'll be looking to just upgrade my platform cuz I don't think I wanna bother with trying to find a used Z170 board that isn't expensive and is in good condition.

But a platform upgrade would cost me about $500 for a 3600 + Gigabyte X570 Aourus Elite + 16GB G.Skill 3600MHz Trident Z RGB.

I know that I could get away with something a bit cheaper like a Ryzen 5 2600 and B450 board for less, but I figure if I'm gonna upgrade, might as well make it worth it.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS