Question No Post when installed in new case, but everything works outside of the case

Feb 14, 2021
4
0
10
0
I recently upgraded my computer. I purchased a Fractal Design Mesify C case and I have a z490 Aorus elite ac motherboard.

Here is the issue. I put together the entire system outside of the case. Everything runs great! I even updated the BIOS and the OS etc while I was waiting on the case...

I installed everything in the case last night and I get nothing. I get 1 flash from the LED on the mother board but no other lights. Fans do not spin etc..
I even tried running a Flash + on it to see if it had the power to do that.. nothing.

Steps I have taken..

  1. Tested PSU.. test passed
  2. Unplugged everything one by one and no change
  3. Removed the CPU to check for thermal paste issues or anything like that.. everything is ok there.
Went to sleep...

Tonight I will be pulling everything back out and seeing if it fires up outside of the case. I that is so then all I can think of is I have a motherboard stand off issue ( which I made sure are in the right spots already ). The board did not come with an I/O Shield so maybe that is the issue?? I am at a loss if it doesn't fire up in the case. To add.. I have been using a screw driver to power it up and I tried that also while it was in the case. Has anyone else had these issues with a case? Would it be caused by the MB contacting the case around the IO area or something? Should I use insulated washers on the standoffs to see if that fixes it?

Ideas would be appreciated!
 

Valorek

Distinguished
Jan 12, 2014
104
0
18,690
1
Gonna take a shot at this haha, when you installed inside the case did you by chance verify all the standoffs are correctly installed and that no screw in loose when you tightened everything down? it's possible something could be shorting the board via standoffs/loose mobo screw/ something touching the board....

I say this because i remember years ago on my first build i could not figure out why my pc would not post, turns out it was one screw on the motherboard that was a 10th maybe less loose. Sounds crazy but you would be surprised what could be the issue. Hopefully this helps!
 

ASK THE COMMUNITY

TRENDING THREADS