Question No post with video card connected, posts without it

Dec 25, 2020
2
1
10
0
Hi everyone, I'm building my 4th pc. (Christmas gift for my son). I've built 3 previously with no issues and this one is driving me nuts. I've read through your checklist and every thing seems to be in order. So here is my situation. If I have my videocard installed and plugged in, I get no post when plugged into the hdmi video ouput from either the video card or from the mother board. If I disconnect the video card, I can post with the HDMI cable plugged into the mother board. with the GPU uninstalled, I have been able to install windows, and update drivers but as soon as I connect my video card, I have no video signal.

According to pc parts picker, there may have been an issue with my CPU and motherboard, I updated the BIOS on the motherboard as well but no change. My next step I think is going to try to use a display port cable in the video card and see if that changes anything, but after that I'm completely lost.

Thank you so much for reading this and I appreciate any help you can give.

My build is as follows...

ASRock B450M PRO4 AM4 AMD Promontory B450 SATA 6Gb/s Micro ATX AMD Motherboard
OLOy WarHawk RGB DDR4 3600 (PC4 28800) 16GB (2 x 8GB) 288-Pin Intel/AMD Ready Desktop Memory Model MD4U083618BEDA
MSI Radeon RX 570 DirectX 12 RX 570 ARMOR 8G OC 8GB 256-Bit GDDR5
Thermaltake Smart Series 500W SLI/CrossFire Ready Continuous Power ATX 12V V2.3 / EPS 12V 80 PLUS Certified Active PFC ...
Crucial MX500 250GB 3D NAND SATA 2.5 Inch Internal SSD
 

Aeacus

Glorious
Ambassador
My next step I think is going to try to use a display port cable in the video card and see if that changes anything
Try that. If it doesn't help, take 2nd, known to work dedicated GPU and try with that one.

If you can boot with 2nd GPU, your RX 570 is dead.
If you can't boot even with 2nd GPU, the PCI-E x16 slot on your MoBo is most likely dead. But you have 2nd PCI-E x16 slot to try as well.

Oh, you might also want to try your RX 570 in 2nd PC, to see if it works there.
 
Dec 25, 2020
2
1
10
0
Update - I did exactly that. Swapped gpu's and everything worked great. Looks like I'll need to send back the GPU. Hopefully newegg handles returns / exchanges ok...
 
Reactions: Aeacus

ASK THE COMMUNITY

TRENDING THREADS