Question No screen on DVI-D after windows load. WHY?

Aug 12, 2019
3
0
10
0
Hi guys I am new here.
I have Intel i5 2320 3.0GHZ Processor.
6 Gigs of RAM (Normal kind).
Asus P8H61-M LE/CSM R2.0 Mobo.
3x Sata Hdds. 1 has window installation.
Asus Gtx 1060 OC3G Gfx Card. (JUST PURCHASED ) (with clean window and driver installation using hdmi cable)
Before had gt730 2gb ddr3 gigabyte rev a1.0
Lenovo Thinkvision L1700P LCD screen 17"

I am using DVI D output from Card to lcd screen without any connectors attached. My problem is that I am not getting any screen after Windows Loading screen. Also even when the systems starting I can't see the Starting Logo amd when i check info on my Lcd it says that its running on 640x 480 (something) resolution.
But when I use HDMI on my Led TV the display works fine and I can play games at Ultra setting. And when i try to plug both Hdmi and DVI-D both at the same time, i dont see anh thing in multiple display in nvidia or windows settings.
So is there anything I can do to get the display work on DVI D.
 

Sagar_20

Reputable
Jun 29, 2016
860
89
5,090
20
Try to boot your PC with the onboard graphics and see if the problem is gone.

For full resolution, you would need to download and install the latest drivers from here, but first make sure to remove all the existing GPU drivers from safe mode.

I would like to know what cable you used to connect to the monitor before.

You can try amazon basics DVI-D to DVI-D 3-feet cable.

May be you are using DVI-I cable (24+5 pin).
 
Aug 12, 2019
3
0
10
0
All the latest drivers are installed. I'll try booting from board connector. I was using vga cable before. Now i bave dvi d , bcz there's no option for DVI I, in card and LCD.
 

ASK THE COMMUNITY

TRENDING THREADS