Question No signal/black screen on a new PC build, gone through the list and nothing worked

Dec 26, 2019
10
0
10
0
Hi all,

I built a new PC and have spent the entire day trying to figure out why I just get a black screen. I've tried going though the troubleshooting list on this site, and bar removing the motherboard from the case I did every other step of the breadboarding process. My mobo doesn't have a little speaker which is a pain too.

It boots up, all fans spin, it stays on indefinitely, the HDD light blinks normally, so does the keyboard - it looks and sounds like it's working just fine; there's just no signal.

I can only think that the firmware on the board needs updating, even though it specifically lists my CPU as compatible (and if that is the problem, I don't know how to go about it)

The compoents are:

AMD Ryzen 2600
Radeon A9 290X
Asus B450M-K motherboard
Corsair 3000mhz ram (16gb)

I'm using a 650w power supply

I'm totally stumped and only have a couple of days to get it working (I'm building it for my kid brother who I'm only visiting for christmas). Help would be hugely appreciated

Thanks
 
Dec 26, 2019
10
0
10
0
What video cable using for connecting the monitor (not tv)? Make sure also that it is connected to the graphics card, and not to motherboard.
To connect to the monitor I used an HDMI cable from the GPU, and also tried a VGA cable from the mobo both with and without the GPU installed
 
Dec 26, 2019
10
0
10
0
Yeah I tried on two TVs as well, using an HDMI cable for each of those, but there was no signal whatsoever :( When I tried on the monitor, it did seem like there was no signal but it did react to me plugging and unplugging the cable (it would be a black screen, then the screen seemed to go into standby after a minute, and then when I unplugged the HDMI cable, it would flicker and then say "No signal" on the screen)
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts