• Enter here for a chance to win a custom MechWarrior 5: Mercenaries themed PC powered by Intel!

[SOLVED] No Signal from brand new Dell S2417DG

Aug 13, 2020
1
0
10
0
I built a brand new gaming pc recently and ran across few troubles. I brought it to a repair shop and they fixed the short circuit in my motherboard and showed at the shop that everything was running smoothly. I come back home plug everything in and connect the pc to the monitor but my monitor reads me that there is no signal and the monitor is going into power saving mode. I am confused because at the shop I saw that the PC was working when connected to another monitor. I plugged my monitor to the display port in my graphics card. Is this a problem with not having updated BIOS or is it the monitor itself. I don't have another PC to go connect it to the monitor and I also can't afford to go back to the shop. Any suggestions and advice would be appreciated greatly.

Specs:
CPU: AMD Ryzen 3700x
MOBO: ASUS X570 Gaming Plus WIFI
SSD: Samsung 970 EVO
RAM: G. Skill Ripjaws V 16 (2x8)
GPU: MSI 2070 SUPER Ventus
PSU: EVGA SuperNOVA 750W Gold
 
Aug 10, 2020
68
3
35
14
Yes, no signal, but usually some other signs that your PC turns on like spinning fans. If your motherboard had a short it should have been replaced as defective. Shorts usually cause secondary damage. If the MB failed after a few months of good operation then the short explanation is questionable unless you leave a loose screw in the case like I did. After a short, I would suspect the PSU next.
 
Aug 10, 2020
68
3
35
14
Yes, no signal, but usually some other signs that your PC turns on like spinning fans. If your motherboard had a short it should have been replaced as defective. Shorts usually cause secondary damage. If the MB failed after a few months of good operation then the short explanation is questionable unless you leave a loose screw in the case like I did. After a short, I would suspect the PSU next.
 

ASK THE COMMUNITY

TRENDING THREADS