Question No signal on monitor

Feb 22, 2019
11
0
10
0
I bought a brand new motherboard Asus p7h55m-pro from Flipkart ..I have assemled it with i5 650 a graphics card ..but when I do power supply there's no signal in monitor ..

Steps I have tried:
  1. Resetting the CMOS
  2. Putting together the parts outside of the case.
  3. Putting ram in single slot also on dual slot
  4. Booting up the PC without the GPU installed
  5. Discharging the power by holding down the power button.
  6. Checking over and over if all the connections are attached to the motherboard.
Mouse lights on.... keyboard lights gives a blink when I press power button to start the PC
Iam using a VGA cable .

I have no idea what the issue is, would value any help
 
Feb 22, 2019
11
0
10
0
Which CPU revision is the i5-650, C2 or K0?

If K0 the board needs to have bios version 1304 or higher to work with that CPU. The C2 should run on earlier bios versions.
Which CPU revision is the i5-650, C2 or K0?

If K0 the board needs to have bios version 1304 or higher to work with that CPU. The C2 should run on earlier bios vers ions.
It's ko and how can I know my BIOS version ? In official Asus site this motherboard s bios version is 1709
 

Zapthos

Commendable
Dec 31, 2016
178
3
1,715
11
It's ko and how can I know my BIOS version ? In official Asus site this motherboard s bios version is 1709
You can see the BIOS version by entering the BIOS. On Asus boards you usually have to press F2 or Del on the startup. You probably need a different CPU to check and possibly update it. I know AMD provides some free CPU's you can use to check/update the BIOS, not sure about Intel.
 
Feb 22, 2019
11
0
10
0
You can see the BIOS version by entering the BIOS. On Asus boards you usually have to press F2 or Del on the startup. You probably need a different CPU to check and possibly update it. I know AMD provides some free CPU's you can use to check/update the BIOS, not sure about Intel.
Problem is I can't even enter bios ..no signal in monitor 😪 thankyou
 

Zapthos

Commendable
Dec 31, 2016
178
3
1,715
11
Problem is I can't even enter bios ..no signal in monitor 😪 thankyou
That's why some manufacturers provide test CPU's. If you want, you can also try using a different monitor cable, like: HDMI, Displayport etc. It may work if you do that, small chance seeing the CPU needs a BIOS update. You can send the MB to Asus, maybe they can update the BIOS for you.
 

RealBeast

Titan
Moderator
Yup, very likely your bios version needs to be updated before you can use that CPU. Motherboard makers rarely ship recent bios versions on their boards. Despite it being an older board it was likely shipped from the factory with a pre-1304 bios.

I've run into that many times. Perhaps you know someone who would let you use an old 1156 CPU that runs on a very early bios version.

edit: or perhaps Flipkart will temporarily loan you ]THIS CPU to do the update since they sold you parts that do not work together as they should. It will run on any bios after 0505, so any version after the first released (which likely you have a version higher than 0401).
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS