[SOLVED] No Signal on Screen

EliJoe0010

Prominent
Sep 15, 2019
20
4
515
0
Hey so my apartment got flooded due to a burst pipe in the washroom and my power strip was on the floor in my office with Tower and the AC adapter for the monitor plugged into it. The monitor is not coming on at all, all i have is a TV (which i have used before) with an HDMI cable to see what is working. But i keep getting No Signal on the screen. How exactly do i test which components are not working? The tower is powering on, no debug lights are staying on...just no display to the tv screen. (Yea i made sure it was on the correct input source) I was thinking to reset the cmos, but i prefer professional assistance. I work from home so this is my only source of income as we are in a State of Emergency in my country. Any assistance and guidance is fully welcomed
 

Lutfij

Titan
Moderator
You will need to breadboard your system innards and then test out the parts one by one. you can work with the motherboard, processor and one stick of ram as your baseline. You cant then add your PSU, and boot device as a step above. If your processor lacks an iGPU, you will need your discrete GPU.

Please be sure to populate the single stick of ram on the slot designated by your motherbaord manual when working with one stick. As for your system, you didn't mention the specs to the build. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
Chassis:
OS:
 
Reactions: EliJoe0010

Lutfij

Titan
Moderator
You will need to breadboard your system innards and then test out the parts one by one. you can work with the motherboard, processor and one stick of ram as your baseline. You cant then add your PSU, and boot device as a step above. If your processor lacks an iGPU, you will need your discrete GPU.

Please be sure to populate the single stick of ram on the slot designated by your motherbaord manual when working with one stick. As for your system, you didn't mention the specs to the build. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
Chassis:
OS:
 
Reactions: EliJoe0010

EliJoe0010

Prominent
Sep 15, 2019
20
4
515
0
You will need to breadboard your system innards and then test out the parts one by one. you can work with the motherboard, processor and one stick of ram as your baseline. You cant then add your PSU, and boot device as a step above. If your processor lacks an iGPU, you will need your discrete GPU.

Please be sure to populate the single stick of ram on the slot designated by your motherbaord manual when working with one stick. As for your system, you didn't mention the specs to the build. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
Chassis:
OS:
Sorry for the delay, just got done finally got done all cleaning and drying.

The specs are
CPU: Ryzen 3 2200g
Motherboard: Msi Gaming Plus B450M
Ram: Corsair 8gb x2 3000mhz
Ssd: Adata 250gb NVME
HDD: 2TB seagate Hybrid & 2tb Seagate
Chassis: Agiler Gamers ATX
OS: Windows 10 pro
PSU: EVGA Bronze 450w BR


Will try the breadboarding method. Thank you!
If you have any further advice based on the parts do let me know as well
 

ASK THE COMMUNITY

TRENDING THREADS