Question No signal. One long beep two short beeps from mobo

Apr 13, 2020
2
0
10
0
Hey guys,

I recently experienced a power outage and I think it fried my graphics card. My mobo is beeping 3 times during start up 1 long one followed by 2 short beeps. I looked it up and I guess it’s a video card issue. I’ve tried unplugging the graphics card and using the intergrated graphics but I’m getting the same beeps. I’ve also tried different hdmi cables, a VGA cable, reseating the graphics card, cleaning the pcie slot, cleaning the graphics card. With no success every time I get the 3 beeps and no signal from the monitor. All my fans work, the leds on the mobo light up, I can hear the harddrive spinning and the psu seems to be in good shape. Any help would be greatly appreciated!

I did order a new graphics card, but I’m worried it’s more then that because I can’t use the intergrated graphics.

My specs

mobo: gigabyte a320m-hd2
CPU: AMD Ryzen 7 2700
GPU: AMD RX 580
HDD: WD 1TB
RAM: Corsair DDR4 8gb x 2
PSU: EVGA
 

popatim

Titan
Moderator
You don't have integrated graphics, you would need a processor with graphics built in and the Ryzen ones end with a G (2200g, 3200g...)
You don't know anyone with an old graphics card laying around so you can see if anything else crapped out??
 
Apr 13, 2020
2
0
10
0
You don't have integrated graphics, you would need a processor with graphics built in and the Ryzen ones end with a G (2200g, 3200g...)
You don't know anyone with an old graphics card laying around so you can see if anything else crapped out??
well that’s good to know. I just assumed it had a integrated graphics because of the hdmi and vga ports. Thanks for the info! I did buy a cheap graphics card to troubleshoot. Should have it soon so I can test it out. Thanks for the help!
 

ASK THE COMMUNITY

TRENDING THREADS