No signal to monitor from new graphics card OR integrated card

Status
Not open for further replies.

skeletree

Honorable
Aug 31, 2012
4
0
10,510
0
Last night I installed a new power supply (Coolermaster RS-500-PCAR) and a new graphics card (Radeon HD 6770) into my desktop PC (eMachines ET1831-07). I made sure to uninstall the drivers from the old graphics card first and everything went smoothly. I installed the drivers for the new card and, after making sure everything was fine, went to bed.

This morning I attempted to play Skyrim, but after a few minutes into the game, the computer shut itself off. It did this a couple of times, so I opened up the computer again and checked everything out. Turns out what I thought was an old graphics card (because it was on the same level as the monitor port like all the tutorials have said so far and I didn't realize I had a ) was the heatsink for the processor. So I put it back in exactly the way it was before I took it out and it works fine when I turn the computer on.

Only now I can't get a signal to my monitor. Neither the port for the new graphics card nor the port for the integrated graphics card is giving a signal, but when I plug the monitor into my laptop, for example, it gets a signal just fine. I checked to make sure everything is securely plugged in to the right places and that the graphics card and RAM and everything is firmly slotted in. So what gives? Should I just take it into a computer repair place? I'm beginning to suspect that I have no idea what I'm doing (please be gentle).
 

trapper

Distinguished
Jun 23, 2005
679
0
19,160
74
It sounds like you burnt out your CPU. Playing a demanding game, even with a heatsink on, can get really hot - without one you're looking at a death sentence for your CPU. I'd look into getting your CPU replaced.
 

ubercake

Splendid
Moderator
Assuming you did replace the CPU cooler properly and both the new power supply and graphics card aren't both bad...

A bad graphics card (or really any other component) with power problems of its own can cause your PC to shut down similarly to how a bad power supply can.

Have you tried removing the 6770 from the PC and using the integrated graphics with the new power supply?

If you can get the PC to run fine off the integrated graphics, I'd exchange the new graphics card.

If you can't, I'd exchange the power supply.
 

skeletree

Honorable
Aug 31, 2012
4
0
10,510
0


I removed the 6770 and the integrated graphics worked fine, so in desperation, I put the 6770 back in and it seems to be working again. It ran a disk check but now it appears to be working normally.

Any idea why taking the 6770 out and then putting it back in didn't work before, when I was checking to make sure everything was in firmly? I'm trying to understand these things a little better.
 

skeletree

Honorable
Aug 31, 2012
4
0
10,510
0


Looks like the CPU is fine, but thank you for the reply. This is good info to have so I can be more careful in the future.
 

ubercake

Splendid
Moderator

It could be that it was in there firmly though not at quite the right angle. This can happen especially if the metal bracket where the video card meets the back of the case isn't seated right. Glad you got it working though.
 
Status
Not open for further replies.