Question No sound on Ubuntu or Windows

Jan 11, 2022
2
0
10
0
Anyone had this before? I have a HP 14-CF2000 laptop, it says "No speakers or headphones plugged in" and "Speaker setup (UNKNOWN)" if I hover over the audio icon in Windows 10. If I hit the F6 mute or F7/F8 vol up down nothing happens, no light. I've uninstalled drivers, reinstalled drivers, updated the BIOS, ran HP support assistant and the Hardware analyser thing, it just says there's no audio device plugged in.

I tried reinstalling Windows (clean drive) and even installed Ubuntu but it only showed Dummy output for the test thing and pulseaudio/alsa fixes weren't changing anything.

If I connect bluetooth headphones, I do get sound and the F6 mute/vol up/vol down buttons perform their functions, but the built-in speakers just aren't responding.
 
There can be a couple of things.

Check your bios settings, see if internal sound card is deactivated somehow ?

Also - have you (or somebody else) ever opened the case? If so, maybe the cable to the speakers are pulled out ?
 
Jan 11, 2022
2
0
10
0
There can be a couple of things.

Check your bios settings, see if internal sound card is deactivated somehow ?

Also - have you (or somebody else) ever opened the case? If so, maybe the cable to the speakers are pulled out ?
Thank you for your response, Grobe.
The bios doesn't show any mention of Audio devices or an option to change it. Main tab shows system components (no audio/video section), Security tab has TPM/Admin password and Config is language / hyperthreading / virtualization. No audio options in those.

And nope never opened it, just sits on the table.

I tried Load Setup Defaults just in case but no dice.
 

ASK THE COMMUNITY