Question No sound when using dual screens ?

Oct 29, 2022
3
0
10
0
Hi. I have an issue when I use dual screen in extended mode. I explain, I have no sound on my tv with hdmi and when my pc screen is connected via vga. But when I connect first my hdmi cable, I have sound and after I connect vga and it works. My principal monitor is set to vga and it must stay because it is used to choose the videos on second monitor. Sorry for my English. I appreciate some help.

Vga monitor : GeChic 2501c
HDMI : TV Toshiba
Mini PC : BT3 box pro
Windows 10
 
Last edited:

Ralston18

Titan
Moderator
"My principal monitor is set to vga and it must stay " - why?

And every time you boot the computer you must disconnect the cables and reconnect to get sound - correct?

= = = =

Update your post to include full system hardware specs and OS information.

Include make and model information for TV (HDMI) and monitor (VGA).

How are the video connections being made: motherboard I/O panel, GPU?

For example:

Motherboard [VGA port] -----VGA cable ---->[VGA port] Monitor/Primary and GPU[HDMI port] -----HDMI cable ------->[ HDMI port] TV/Secondary

Edit and correct as necessary. No adapters being used. What is printed on the HDMI cable?
 

BFG-9000

Distinguished
With VGA as primary, the sound device will default to analog sound on boot.

You can select digital audio as your default device by opening the Control Panel Sound settings either by commandline (control mmsys.cpl sounds) or under "related settings" of the "Open Sound Settings" app (where it's Sound Control Panel).

Click on the High Definition audio device associated with the video card driving the secondary monitor and click "Set Default"
 
Oct 29, 2022
3
0
10
0
Thanks BFG-9000, my LCD TV is already set to default. I don't understand. I test again this evening, I have to turn on the computer with HDMI cable connected to TV to hear sound at the beginning of Windows and when I hear it, I plug the vga cable to have the dual screen with HDMI audio. Else, if the vga and HDMI cables are plugged in before I turn on my mini Pc, there is no sound. It makes me crazy
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS