Question No sound with MSI RX580 8Gb

haunter528

Commendable
Oct 19, 2017
7
0
1,520
1
I am trying to get audio through HDMI to a Samsung TV.

PC parts:
AMD Ryzen 5 2nd Gen 3400X
MSI Radeon RX580 8Gb
MSI Carbon x370 Gaming Pro (BIOS up to date)
16Gb RAM
Windows 10 x64 - 1909 (up to date)
Adrenalin 2019 Edition 19.9.2(WHQL) also try with Adrenalin 2019 Edition 19.11.3


Here are the details and issue:

Without GPU: If I use integrated graphics rx vega 11, the sound works fine hdmi to TV.
With GPU: If I connect hdmi to tv, video works fine but no audio, I have try both hdmi ports on rx580.
I have tried with both drivers, using DDU to switch between drivers.
With GPU: If I go to the sound icon, I can only see Digital Audio(S/PDF), I cannot see the TV listed as an option for audio output.
Without GPU: If I use the integrated graphics, If I go to the sound icon, I can see the TV as default and the Digital Audio(S/PDF).
I have another rx580, and the same issue with both cards.
With GPU: If I plug an USB headset, audio works fine through USB.
With GPU: if I go to device manager, under Sound..., there is only 1 device listed.
When I go to Radeon settings, System, Software: AMD Audio Driver Version: 10.0.1.12

Initially Y built the PC with all the parts listed, when I notice that there was no audio,
I uninstall the GPU and use integrated and the sound worked without GPU.
I then went to safe mode, use DDU, uninstall drivers and shut down, I reinstall the GPU but same issue, no audio.

Any help will be greatly appreciated!
 
Last edited:

haunter528

Commendable
Oct 19, 2017
7
0
1,520
1
UPDATE:

Here are some things that I have tried:
Downgraded BIOS 2 versions,
CPU stop working,
used and an old CPU (AMD A8),
There was sound coming from the GPU,
upgraded BIOS 1 version,
Still using A8, there is sound in GPU,
Switch back to Ryzen 5,
Won't boot (MOBO is from 2017ish and CPU from 2019, there are some know issues)
Switch back to A8, upgraded to latest BIOS,
Again, no sound.

I need the latest BIOS because it works with ryzen 5 but it causes problems with GPU.
version 7A32v1NU(Beta version) works with MOBO and Ryzen 5 but causes GPU issues
version 7A32v1L won't work with MOBO and ryzen 5 but it works with A8 and GPU
version 7A32v1K won't work with MOBO and ryzen 5 but it works with A8 and GPU
 

ASK THE COMMUNITY

TRENDING THREADS