Question No surround or bass on 5.1 speakers after Windows 10 reinstall ?

roche28

Reputable
Apr 13, 2017
9
0
4,520
1
Hello everyone,

a few days ago I decided to upgrade my system. After installing the new components, B460 Phantom Gaming 4 motherboard, Intel i5 10400f cpu and 2060 rtx graphics card, I had to reinstall Windows to get it working, and decided it is probably a good idea to format my OS drive as well.

Everything is working now, except my 5.1 speakers system. They play all sounds on the front speakers only, no rear, center or subwoofer. When I test individual speakers in Realtek Audio Console, they all work fine and there is bass coming from the subwoofer, just like before. But when I do anything else, music, videos, games, only the front speakers work and there is no bass, it sounds flat.

I've tried just about everything I could find on the internet, all available sound options, installing various drivers, but still no solution.

The strange thing is it was working fine just before the reinstall of Windows, and I think it was the same version as now. I've checked, and there are no new updates available.

If anyone has any ideas what to try next, I'd be grateful.
 

roche28

Reputable
Apr 13, 2017
9
0
4,520
1
So I managed to solve the problem, sort of.

After a lot of tinkering with audio drivers, I ended up installing both the Realtek Audio driver and Nahmici 3 provided on the cd with my motherboard. Then I updated Nahimic 3 to the latest version from ASRock's website. Once I enabled surround sound in Nahimic, my bass was back for music and videos, but not in games.

After some more tinkering with settings, it turns out to have bass in video games, I have to disable rear speakers and also surround speakers option in Realtek Audio console, and enable bass management. Now I can even turn off surround sound in Nahimic 3, and get bass in everything. I also disabled center speaker, so it sends all the sounds to the front ones.

Not an ideal solution for someone who wants the full surround experience, but since I have all speakers in front of me, I only care for front speakers and subwoofer, so I'm fine with it.

This was all done after i reinstalled again the version 1903 of Windows 10, and disabled all updates completely. The bass management option is broken in newer versions and causes no sound at all, but it is required for the subwoofer to work properly.
 

ASK THE COMMUNITY

TRENDING THREADS