Question No TV video out of AV receiver

kn4hh

Prominent
Jun 2, 2020
9
3
515
0
I just purchased a Yamaha TSR-700 receiver and I am trying to configure it to work with my Xfinity TV service and a Samsung LN32B640R3FXZA television. With my Xfinity X1 cable box directly connected to the TV via a HDMI cable, audio and video is good. I removed the HDMI cable from the TV and connected the HDMI cable to a HDMI input on the Yamaha receiver. The receiver detects and identifies the Xfinity signal. With the Yamaha receiver connected to the TV via HDMI , the TV detects the Xfinity signal. When I select that input, the screen goes blank and no video or audio is received.
I would appreciate any suggestions.

Thanks, Bob W.
 

kn4hh

Prominent
Jun 2, 2020
9
3
515
0
How do you know that if you see nothing on the TV?
If you select another input on the receiver, like tuner/Net, do you see anything on the TV?
Sometimes, HDMI is picky about cable' quality.
The TV does work with my Blue Ray player as well as my old VHS and CD player. I have changed HDMI cables, which say they support 4K, and no change. I have tried other HDMI inputs on the TV and no change. Everything works except HDMI video feed from the AV receiver.
 

kn4hh

Prominent
Jun 2, 2020
9
3
515
0
So sorry, folks. Maybe i am missing the whole concept of the role of the AV receiver. They show all peripherals being connected to the AV receiver and the one HDMI output routed to the TV . My TV does not support ARC. Don't know if this is why I get no video to the TV from the AV receiver or not. If I connect my cable box directly to the TV and use the optical digital audio connection between the TV and AV receiver, I do get audio to the home theater speakers. A real novice here.

Bob W.
 

ASK THE COMMUNITY