Question No video output after Asus B350-F Motherboard Bios update

0xc

May 28, 2019
1
0
10
0
Hi,

I have a pc with a B350-F mainboard (full pc specs at the bottom). When i received it i immediately updated the bios to the newest version. With Asus Ez Flash that worked absolutely fine. I've used the pc for more than a year and there weren't any big issues.

Today i thought I'd do a bios Update since ...well, why not? It's pretty easy with the Ez flash function, right? Hahahaha, no.

I've downloaded the correct bios file from the Asus homepage, extracted the zip and placed the *.CAP file on a empty 8GB FAT32 Usb stick.

I booted into bios, went to the Ez flash tool, selected my usb stick and selected the *.CAP file. It told me which bios version is going to be installed and i clicked 'OK'

The installation took a few minutes but it finished and then a message came up saying that the bios update was successful and my pc is going to be rebooted. I clicked 'OK' again. After +30 minutes my PC still didn't reboot and i was stuck at a black screen. I was pretty sure that the PC is not going to do anything by itself so i turned it off.

I turned my pc on again. Cpu and gpu fans are spinning, HDD is making noise, pc makes regular sounds, BUT there is no video output. I tried to connect my PC and my TV with HDMI and DP and tried to use GPU and then Mainboard but no matter what i do there is no video output. Like I said all fans are running but f.e. my Usb mouse and keyboard won't turn on.

Since i didn't reset my bios to the default values before updating i thought i'd clear the CMOS. I tried to do it the way it's explained in the manual but with and without battery it doesn't seem to change anything.

I removed the battery for +30 minutes but i got the same result as before. (A while ago I had 2 times after a crash the problem that i wouldn't get any video output. Removing the battery for about 30 minutes always fixed the problem for me.)

Asus also has the CrashFree recovery tool that helps with corrupted bios installations and the instructions are simple: put bios file on usb, boot pc with usb connected, ez flash will start automatically

This unfortunately didn't work no matter where i connect the usb.

I thought this would be a quick and "ez" bios update but instead I'm now stuck with a broken PC.

I googled for a long time and found people with similar problems but i wasn't able to find a helpful solution.

I also couldn't find a video tutorial on how to reset the CMOS on the B350-F so i just did exactly what the manual said.

What can i do now? Thank you very much to anyone who tries to help me!

----- Pc specs -----

MOBO: Asus Rog Strix B350-F

CPU: Ryzen 1600, Stock cooler

GPU: Powercolor RX 480 8Gb

RAM: 2x 8 Gb Corsair DDR4

PSU: Thermaltake 600W

DISK: 1x SSD 500GB, 1x HDD 3,5" 2TB , 1x HDD 2,5" 4TB

If i forgot something feel free to ask
 

Aeacus

Glorious
Herald
Updating BIOS isn't something you can do on a whim. BIOS update, as such, is only viable when you know for a fact that newer BIOS fixes the specific issue you have with your PC. (E.g if i want to use Kaby Lake CPU with my Z170 chipset MoBo, i need to update my MoBo BIOS.) If there are no issues, there is no reason whatsoever to update BIOS. Just because you "can" update BIOS doesn't mean that you "have to".

Most MoBos never get their BIOS updated and work fine until they are obsolete. Sometimes, MoBo can see 1x BIOS update in it's life but any more and you're risking bricking the MoBo. Due to that, my best guess is that you've damaged the MoBo BIOS chip and now, you have corrupt BIOS. PC won't run when MoBo has corrupt BIOS and only fix is MoBo replacement.

This here is what i call a life's tax.
 

ASK THE COMMUNITY

TRENDING THREADS