Question No Video Output from GTX 1660

Dec 31, 2020
2
0
10
0
Hi, Luke here

This afternoon I turned off my computer and came back to it later in the evening to find that after turning it on the graphics card was not providing an output. I tried switching from DisplayPort to DVI, then HDMI to make sure it wasn't the cable, and still no luck. The monitor is working as I plugged my laptop into it and it worked as normal. I'm going to test the onboard graphics to ensure it isn't a problem with the computer itself, although I'm not sure how to switch to onboard graphics. The fans on the graphics card are spinning so I am assuming that it is recieving power from the power supply.

PC specifications:

ASUS Prime A320M-K AM4 Motherboard
2 x 8GB DDR4 DIMM Memory
240GB SSD
GeForce GTX 1660 6GB Graphics Card
Unsure about PSU. I know it's 500w and it reads on the side "be quiet!"

AMD Ryzen 7 2700 CPU with Wraith Cooler
In use since December 13th 2019

If you need any more information please let me know.
 

Wolfshadw

Titan
Moderator
Unfortunately, you do not have on-board graphics. Your processor doesn't have it, so that's not going to work. Best thing you can do is take your graphics card to a known working computer (with sufficient power) and test it there. If it works there, it is likely your power supply.

-Wolf sends
 
Dec 31, 2020
2
0
10
0
Unfortunately, you do not have on-board graphics. Your processor doesn't have it, so that's not going to work. Best thing you can do is take your graphics card to a known working computer (with sufficient power) and test it there. If it works there, it is likely your power supply.

-Wolf sends
Don't have access to many computers due to lockdown restrictions, but I'll take a look and see what I can do. What a great way to end 2020 eh?
 

ASK THE COMMUNITY

TRENDING THREADS