Question No Video Output from RMA'ed 1080

CorMazz

Honorable
Sep 13, 2013
29
0
10,530
0
Windows 10 Home 64bit
EVGA GTX 1080, just got here after an RMA
i5-8600k 4.5 GHz
AS Rock Z370 Killer SLI/AC Motherboard
Corsair RM650X 650W PSU
16 GEIL DDR4 @ 2,132 MHz

Tldr: PC starts up, but has no video output with GPU, yet works fine on integrated graphics.

Hello everyone. I was recently having GPU issues, which I isolated by putting a different, AMD GPU in my PC and testing its stability. (I also changed my PSU to make sure my PSU didn't brick my GPU.) I then RMA'ed my 1080 with EVGA, and they just sent me another card. The problem is, I cannot get this card to output a video signal. The PC turns on, everything lights up, but there is no video output. I reset the CMOS with the jumper pins, I changed which PCI slot my GPU was in, I tried both HDMI and DVI outputs (I selected the source on the monitor and am 100% certain the monitor works). I just tried to start up the PC without the GPU in, and it started up just fine and had video output on the integrated Intel graphics (I plugged the HDMI cable into the MOBO ports vs. the GPU ports because the GPU wasn't in the PC, obviously).

I thought that maybe there was some sort of driver interference between the AMD Radeon software and the GTX1080 I was trying to run, so I uninstalled Radeon, and then ran the AMD Driver Cleanup Utility, which said it successfully removed all AMD drivers. Upon putting the GPU back in, however, there was again no video output.

I have no idea what could be going wrong here. I will try and get another GPU to test out my MOBO, and perhaps I will soft reinstall windows. Any suggestions?

Thank you,
CorMazz

Edit: just reset windows, no change. Working on getting another GPU to test this weekend.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS