• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

No video output (with video card or onboard) with Gigabyte Z370 Aorus Ultra Gaming 2.0

Nov 26, 2018
7
0
10
0
I am building my new gaming PC. I have assembled it with the following components:

- Motherboard: Gigabyte Z370 Aorus Ultra Gaming 2.0
- CPU: Intel i9-9900K
- CPU cooler: NOCTUA NH-D15
- GPU: PNY GeForce RTX 2080 Ti
- Samsung 970 PRO 1TB NVMe M.2

As soon as I try to boot up, the VGA light on the MB lights up solid for a few seconds, then the system reboots automatically. I get no video output at all. I also tried to remove the video card and tried to get some video output through the on-board / CPU graphics, but without success. Same result.

On the Gigabyte website I found the information that the support for i9 processors was added in a (maybe) later BIOS version than I have. But I don't know how to update BIOS without video output and with my system rebooting after a few seconds over and over again. Also the CPU light on the MB does not light up, which it should do if the CPU was not supported, I suppose.
 
It may need a BIOS update to support that CPU since it's 9th gen. The mobo is 8th gen

Intel Core i9-9900K 3.60GHz 16MB 350 MHz / 1200 MHz Coffee Lake 14nm P0 95W 100 F10

Thats the tricky bit. You'll need a lower spec CPU to flash the BIOS, then install this CPU
 
It may need a BIOS update to support that CPU since it's 9th gen. The mobo is 8th gen

Intel Core i9-9900K 3.60GHz 16MB 350 MHz / 1200 MHz Coffee Lake 14nm P0 95W 100 F10

Thats the tricky bit. You'll need a lower spec CPU to flash the BIOS, then install this CPU
 
Nov 26, 2018
7
0
10
0
I went to my local computer store and they recommended to buy an CPU of 8th Gen. (which I can use for flashing and then return it), because an older CPU might not work. So I bought an Intel i3-8100 and it finally booted. Then I flashed the BIOS and got my i9 to work. Thanks everyone.
 

ASK THE COMMUNITY