[SOLVED] Not able to install 64 bit windows 10 (32 bit installed correctly)

Dec 16, 2020

I have recently built a computer. My system configuration is
  • CPU - Ryzen 3 3100
  • Motherboard - Asus A320M-K (I updated it to latest bios version 5603)
  • GPU - Zotac 1660 super AMP
  • RAM - G-Skill Ripjaws 2 * 8 GB 3200MHz
  • HDD - WD 1 TB 7200 rpm
  • PSU - Corsair CV450
In bios, I am able to see all my components. I have disabled fast boot and secure boot. CSM is enabled.

I am trying to install window 10 from a USB (created using media creation tool as well as Rufus). It boots into the USB, loader completes half circle and then it goes back to black screen and everything starts again (video added). I tried installing 32-bit windows 10, and it is getting installed correctly. Same thing happens with Ubuntu as well. I tried Ubuntu LTS versions 20, 18, 16 (all 64-bits), I got AMD-vi connection timed out exception (screenshot added). I was able to install 32 bit Ubuntu 16.

imgur link to video and screenshot

I am not able to install any 64 bit OS. Can someone please help me?

Edit: If I disconnect hdd, then I am able to see windows setup screen, but i don't think its possible to install windows without hdd in system. Is there any bios setting related to SATA that I need to check?
Last edited: