Question Not getting image after replacing bios chip

xsnowstormx

Prominent
Dec 24, 2017
3
0
510
0
My motherboard's bios died about a month ago, when I tried to update the bios, but it failed. It got my pc stuck in a boot loop, I pressed the power button, but it turned off about a second later everytime.
I tried removing the cmos battery, using the clear bios pad, but nothing worked.

I eventually identified the problem, it being my bios chip that got corrupted. I couldn't find any chip replacements, but I found a faulty (not the same problem as mine) motherboard of the same brand and model as the one I have.
I replaced the bios chip, and the pc turned on, but it doesn't display any image or turn on any usb peripherals.

I also put the original chip back in to see if that was exactly the issue, and it was.
I think the issue is that the motherboard I bought, despite being the same model, is a different revision, which could be the reason why my motherboard doesn't show the bios. But I'm not sure.

Is there any way to reprogram my original chip? I believe that it's the only way I'll make it work, and I don't have the money to buy a new motherboard (and even if I could, I'd have to upgrade it).

My motherboard's model is an ASRock H110M-HDS (image below, the arrow points to the bios chip).
 

ASK THE COMMUNITY

TRENDING THREADS