Question Not getting the most out of hardware?

FavouriteBroom

Distinguished
Nov 11, 2013
19
0
18,510
0
First off here is a bench mark I did, I did upgrade to 32gb ram dual channel c16

https://www.userbenchmark.com/UserRun/45069515

I just can’t seem to always get what I should out of these specs, lately I played days gone and chernobylite for higher graphic games, I gotta keep v sync on as on my monitor (tv) the screen tearing was really bad. I do get random drops to 30 fps for a split second in both games maybe every 10 minutes or so? Maybe longer, nothing that bothers me, but I do notice them.

I will update how these perform at 4K or 1440p as I’ve been playing those two in 1080p prior to now.

now here are two games where no matter what I do I can’t keep the game at a stable 60fps the biggest one being Aoe2 def edition. Oh boy this one just absolutely hates me, before I was playing on a monitor at 1080p only 55 hertz but I would get consistent frame drops while playing. Even when I uninstall Uhd pack. On the 60hertz 4K tv it gets even worse, consistent 18-30 fps even if I disable all advanced graphics and lower the resolution to 1080p (looks terrible on my 70 inch tv) I still get those consistent numbers. Nothing much is even happening is the worse part.

As for the other game, I am assuming it’s due to age but warcraft 2 I keep getting frame drops while playing.

No matter what I buy or do I just can’t see to run anything flawlessly without issue, I look online at what systems similar to mine run these games at and they’re almost quadruple or more fps then I get on average. I can post up so more info tomorrow if needed,
 
First off here is a bench mark I did, I did upgrade to 32gb ram dual channel c16

https://www.userbenchmark.com/UserRun/45069515

I just can’t seem to always get what I should out of these specs, lately I played days gone and chernobylite for higher graphic games, I gotta keep v sync on as on my monitor (tv) the screen tearing was really bad. I do get random drops to 30 fps for a split second in both games maybe every 10 minutes or so? Maybe longer, nothing that bothers me, but I do notice them.

I will update how these perform at 4K or 1440p as I’ve been playing those two in 1080p prior to now.

now here are two games where no matter what I do I can’t keep the game at a stable 60fps the biggest one being Aoe2 def edition. Oh boy this one just absolutely hates me, before I was playing on a monitor at 1080p only 55 hertz but I would get consistent frame drops while playing. Even when I uninstall Uhd pack. On the 60hertz 4K tv it gets even worse, consistent 18-30 fps even if I disable all advanced graphics and lower the resolution to 1080p (looks terrible on my 70 inch tv) I still get those consistent numbers. Nothing much is even happening is the worse part.

As for the other game, I am assuming it’s due to age but warcraft 2 I keep getting frame drops while playing.

No matter what I buy or do I just can’t see to run anything flawlessly without issue, I look online at what systems similar to mine run these games at and they’re almost quadruple or more fps then I get on average. I can post up so more info tomorrow if needed,
What part are you referring to as underpreforming???? Everything is right where it should be if not even higher performance then most..... then ram may seem like it is having a issue but no... that is how ram will always be with windows.... since it has so much going on all at once even when idling it's calculating.
 
First off here is a bench mark I did, I did upgrade to 32gb ram dual channel c16

https://www.userbenchmark.com/UserRun/45069515

I just can’t seem to always get what I should out of these specs, lately I played days gone and chernobylite for higher graphic games, I gotta keep v sync on as on my monitor (tv) the screen tearing was really bad. I do get random drops to 30 fps for a split second in both games maybe every 10 minutes or so? Maybe longer, nothing that bothers me, but I do notice them.

I will update how these perform at 4K or 1440p as I’ve been playing those two in 1080p prior to now.

now here are two games where no matter what I do I can’t keep the game at a stable 60fps the biggest one being Aoe2 def edition. Oh boy this one just absolutely hates me, before I was playing on a monitor at 1080p only 55 hertz but I would get consistent frame drops while playing. Even when I uninstall Uhd pack. On the 60hertz 4K tv it gets even worse, consistent 18-30 fps even if I disable all advanced graphics and lower the resolution to 1080p (looks terrible on my 70 inch tv) I still get those consistent numbers. Nothing much is even happening is the worse part.

As for the other game, I am assuming it’s due to age but warcraft 2 I keep getting frame drops while playing.

No matter what I buy or do I just can’t see to run anything flawlessly without issue, I look online at what systems similar to mine run these games at and they’re almost quadruple or more fps then I get on average. I can post up so more info tomorrow if needed,
https://dlcdnets.asus.com/pub/ASUS/mb/03CHIPSET/DRV_Chipset_AMD_AM4_SZ_TSD_W10_64_V20504352_20200716R.zip
Download and install this ignore the prompt if it tells you you already have this do you wish to reinstall click yes if tells you, you have a newer version REPLACE please it is windows thought to he drive for the board it does this to me I had to disable driver updates. Mines the b450-f gaming
 

FavouriteBroom

Distinguished
Nov 11, 2013
19
0
18,510
0
https://dlcdnets.asus.com/pub/ASUS/mb/03CHIPSET/DRV_Chipset_AMD_AM4_SZ_TSD_W10_64_V20504352_20200716R.zip
Download and install this ignore the prompt if it tells you you already have this do you wish to reinstall click yes if tells you, you have a newer version REPLACE please it is windows thought to he drive for the board it does this to me I had to disable driver updates. Mines the b450-f gaming
I’ll give it a looksy! Don’t suppose you’ll let me know exactly what it is before I hit the link?
 
Yeah my SSD isn’t always this full, and a lot of things are still on my HDD.

a friend of mine said I should snatch the drivers are AMD.con
Well if you don't have your graphics drivers that would make since bit according to userbenchmark you have some sort of drivers already installed you just need to update possibly but that again shouldn't cause this issue it sounds more like a lag of some sort between the cpu gpu and ram somewhere which generally represents chipset driver issues cpu issues sockets issues cpu pcie dimm sockets
 

ASK THE COMMUNITY