• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

not showing cd/dvd drive

anshu007

Honorable
Jul 12, 2013
1
0
10,510
0
I have problem with my cd/dvd drive.It is not visible in "My computer".
The power connection of the cable is ok as i am able to eject or close the drive.using window 7 solve my problem
 

Nickolie

Distinguished
Jan 29, 2008
133
0
18,710
10
Make sure the cables are plugged in correctly. Just because it's powered doesn't mean your computer will recognise it - You need to make sure your SATA cable is plugged into the Mobo.
 

Nickolie

Distinguished
Jan 29, 2008
133
0
18,710
10


Not true. Windows 7 still shows the DVD drive when it doesn't have a disk in the drive.

 

USAFRet

Titan
Moderator


Well...I'm looking at my Windows Explorer right now, and it does exactly that. No DVD drive appears until I insert a disk.
 

boju

Illustrious
Yea i was thinking the same thing Nickolie, maybe was confused with something else, anywho;

Anshu, when you open "my computer" click on the arrow next to 'Devices with removable storage' I'm hoping its minimized and will show the drive when expanded.
 

USAFRet

Titan
Moderator
Win 7 Ultimate:

Open Windows Explorer
Left pane shows:
Local Disk C (Os partition)
Local Disk D (Win 8.1 partition)
Various mapped drives

We do not see an E until and unless there is a disk in the drive


Click on Computer
In the right pane we do see it listed under "Devices with Removable Storage"
 

boju

Illustrious
ok i see now. First time i seen that, did exactly what you said when i inserted a cd, must be just the way windows is.

In my computer the cd/dvd drive is missing the op is saying, im guessing the arrow may have been clicked to hide it.
 

boju

Illustrious
lol i think we're getting confused with the 'my computer' thing. Its been a long time since using winxp but had used it for many years, wasn't there an icon with 'my computer'? pretty sure there was and win7 renamed it to just computer. I'm guessing phrase used in the ops question was literally taking into account its my computer. o:

Confused.

 

USAFRet

Titan
Moderator


Well...he's got this tagged as "Windows 7". We'll just have to wait and see his response.
 

boju

Illustrious
no thats what i mean, up until this moment. im being honest now lol, it might sound dumb, but till this moment ive always thought of it as my computer until i looked at it properly since this thread and things have now changed lol. Maybe its the same for the op ;P
 

USAFRet

Titan
Moderator


Right. XP and earlier, it was 'My Computer'. 7 & 8, just "Computer'.
 

cadillacmike

Distinguished
Jan 3, 2012
3
0
18,510
0
Old thread, but this was bugging me. This is Win 7 pro 64.
Half of my computers show the DVD drive even when there is no disc in the drive (in win explorer / file mgr), but the other half wouldn't. Put a disc in and it shows up as E:. Take the disc out and bye bye. These were ALL machines restored from the SAME backup onto very similar ThinkPad T61s. It drives me crazy because when I put in a USB, it will grab the E: drive letter that is supposed to be for the DVD drive. I have backup / sync routines that want the USB sticks to be G: or H:. These machines usually have internal or local attached drives C, D, E, and F already in use and the USBs are G and H.

I found the setting. It's in Win explorer.
Tools / Folder Options. General Tab.
Make sure the box that says Show All Folders it checked and the empty DVD drive now shows up!
 

phatdaddy

Prominent
Mar 9, 2017
1
0
510
0


Windows 10 solution is basically the same but the names are changed to confuse the innocent!
Open File Explorer
Click on "View" tab, then click on "Options" (way off to the right side)
Click on "View" tab and scroll Waaaaay down to the bottom and click/check the box "Show all folders"
and like CaddilacMike says, there it is!

I like this forum!
 

Similar threads