NOT Solved - RAID0 Help!


Feb 23, 2010
I have 2 Western Digital 1TB HDD (WD1001fals) with Windows Vista 64 and in a RAID0 setup. I attempted a normal restart and my Intel Matrix Storage Manager is indicates that one HDD shows "Error Occurred (0)" in red and "Member Disk (0)" in green for the other. Both were at "Member Disk (0)" in green prior to this restart.

What has been tried:
memtest86 - passed all
Boot Normally to Windows: System hangs for 1+ hours.
F8 to Safe Mode (all options tried): System hangs for 1+ hours.
Last known working configuration: System hangs for 1+ hours.
Inserted Windows Vista 64 disk to attempt recovery console: "Windows failed to start. A recent hardware or software change might be the cause." has a Status: 0x0000225 and Info states: "An unexpected Error Occurred."

With the help of sub mesa, I installed and ran Ubuntu to examine the smart utility information. Unfortunately, I haven't heard a response from pm or email about the next step.

OP was mistakenly marked solved and locked by an admin.

Screen shots:

I sadly have years of data on the drives that I recently moved over to burn to Blue Ray. I could really care less about the music and data but it's all the pictures I had that are irreplaceable. If you can help in any way, I would greatly appreciate it.

The OP can be found here with the Ubuntu results:

sub mesa

audiohere, sorry i did not reply in your topic; i must have missed it.

Would you still like to try the Ubuntu recovery method?

You posted the SMART data from both your disks. These say that both disks have a pending sector (1). That's very bad, because it means any attempt reading it will fail with a timeout. RAID arrays don't like that. So this is probably what caused your broken array.

You can do two things:
- write zeroes to the bad sector on both disks (each have one bad sector) so the damage is fixed but you have 512 bytes of corruption on your disk (might not be so bad)
- use Spinrite to attempt to recover and fix the damage on the harddrives without destroying any data. If it works, its the best option.

So before we can use the Ubuntu RAID engine to recover data, we should fix the (physical) damage on your two harddrives. Please tell me if and how you would like to proceed.


Feb 23, 2010
Sub mesa, thanks for your reply. I am running Spinrite 6 on one of the drives now.

I purchased 2 more FALS1001 drives and setup the exact configuration and I've been having the same issue with these 2 new drives. I can boot with raid configured and 1 time out of about 20 restarts, I can see both drives but OS will sometimes boot and other times won't.

Once I do get the OS to come up, I open Intel Matrix Storage Manager and it shows an error on one of my drives. I reset the disk to normal and typically I don't have any time to move data for recovery.

sub mesa

If spinrite works, it should have fixed the two pending bad sectors; each on one HDD. This is important because our recovery procedure might fail if the device(s) still have bad sectors.

After you've used Spinrite to fix the damage, boot Ubuntu again, open a terminal, and use SMART:
sudo apt-get install smartmontools
sudo smartctl -a /dev/sda
(repeat for second disk; /dev/sdb)

In the output that follows, you should see "Current Pending Sector" having a RAW_VALUE of zero (0). If it is still 1, then Spinrite didn't fix it and you may have to write zeroes to it.

It spinrite worked, check again if Ubuntu can access your data:
- click Places, click Home
- click "... GB Filesystem" on the left side in the window that opens
- you should now see your data

If there is no ".... GB Filesystem" then Ubuntu did not detect your RAID automatically; we may have to do this manually. Please give me an update as of the status of spinrite/bad sectors and whether Ubuntu can access your data at this point. If not; we'll continue with manually recovering RAID0.


Feb 23, 2010
OK, so understanding that now I have 4 hard drives total, the original 2 (great deal of data that was recently moved), RAID0 with Vista Ultimate 64 and the additional 2 (data I was willing to part with), RAID0 with Windows7 Ultimate 64. The problem duplicated itself with the Windows7 build.

I burned an iso of Spinrite, booted to win7 drives in RAID mode and I kept getting Initdrv with a flashing cursor. Asuming it was unable to innitiate the drive, I flashed BIOS and reset with a non RAID setup, disconnected 1 drive and ran Spinrite.

Spinrite ran about half way through and returned an error: Divisional Overflow Error! Occurred at: 5672 and some other technical information I took a screen shot of. I powered down the PC, swapped the SATA cable and booted with Spinrite again, using the other drive. This process was not as intailed and returned the same error a short time through.

I reconnected the SATA cables to the original RAID connections, flashed the BIOS, booted and selected a RAID setup, rebooted intobios again to configure settings and Windows 7 worked fine with no errors under the Intel Matrix Storage manager upon boot. I was able to retrieve my data and then removed the drives.

I then installed the original set that I really need to get the data from and followed through the same process. When I ran Spinrite with each drive individually, the first drive I connected returned the same Divisional Overflow error at 5672. The second drive showed a “Drive 0”, “Gap” and “Part 1”. I could scan Drive 0 and Gap fine but when Part 1 was selected, it returned a red lettered message saying:

“Invalid Partition for Drive Size. This Partition exceeds the size of this drive as defined by the system’s BIOS or BIOS extension. You should NOT PROCEED to use SpinRite on this drive until you have verified and corrected the desparity between this drive and the BIOS’s or BIOS extension’s understanding of the drive size.”

Just for kicks, I ran Ubuntu again and still see no "... GB Filesystem" under Places.

I feel like if I can get Intel Matrix Storage manager to work in Ubuntu, I may be able to temporarily fix the issue so that I can back up my data. Intel Matrix Storage Manager is the Windows based UI that allowed me to reset an Unknown Error (0) disk back to normal. I found an article about IMSM in Linux but I'm too newb to understand the Linux lingo. The link:

sub mesa

You obviously spent some time trying to get your data back, and it didn't work automatically in your case.

Instead of coming will all kind of technical suggestions, i suggest something else:

- install FreeBSD to a new/clean disk
- open up network access
- give me the root password

Though it obviously requires you to trust me, i would be able to reconstruct your RAID array and do either two things for you:
- recover all data with NTFS-3g which reads NTFS filesystem (only possible if undamaged)
- if the NTFS filesystem is damaged, you cannot access the data in BSD. But you can write the contents of the RAID to a single disk. So; you buy a 2TB disk that is large enough to hold the data of both 1TB disks in RAID0; then i do a raw byte copy from the RAID array to the new 2TB disk. Now you connect that 2TB disk to windows and use windows recovery applications to recover your data.

Otherwise said, i believe this would give you the best chance at recovering your data. Once i'm logged in to your system, using SSH, i should only need a few minutes to mount your filesystem and allow network access so you can copy the data off the network to your windows pc.

If you feel this is a good plan, all you need to do is follow my FreeBSD install tutorial over here:

*** PLEASE *** make sure that if you do this, you disconnect all disks except the system disk FreeBSD can use to install to; use any old 20/40GB disk you can find; but DISCONNECT all other disks. Otherwise, you can make the mistake of installing FreeBSD to one of your RAID disks; you do not want that to happen.


Jul 25, 2006
I would strongly suggest Raid reconstructor + Captain Nemo. I was in a similar situation when bad sector developped on a hard drive and Intel Raid just failed. Had to recover both RAID0 and RAID5 arrays. HEre's how you do it.
1. Disable intel RAID in BIOS.
2. Disconnect your two drives with your data.
3. Connect a spare drive install windows and raid reconstructor + captain nemo.
4. Connect your two drives with your precious data but again make sure they don't come up as raid.
5. Run raid reconstructor and go through wizard to create a virtual image file.
6. open it with captain nemo. It should mount your lost partitions and you should be able to browse files like in explorer. If that does not happen go back to raid reconstructor and make sure hard drive sequence and strip size is correct. with only two hard drives it involves very little guesswork and you should get it right eventually. Remember to save modified virtual image file before reopening it with captain nemo.
7. Restore your files to another drive or a network share and praise for their wonderful tools.

good luck
Andrius S


May 31, 2012

Thanks for this! I had a 2-disk RAID-0 where one of the drives developed a bunch of bad sectors and prevented the RAID from booting, and this worked beautifully.

One minor difference in what I did - I had a Dell PC with a built-in RAID controller on the motherboard, where the BIOS did not allow turning RAID off on existing disks already configured for RAID, so I skipped step 3 and instead connected the two RAID disks to another Windows PC I had handy. This allowed me to skip finding a spare drive and installing Windows, which was a good thing.

I should also mention that the fully functional non-eval versions of RAID Reconstructor + Captain Nemo together cost about $180 - a decent chunk of change but still considerably less than paying a data recovery company to restore your data!