Nothing happens when I press the power button

Ultramason

Reputable
Jul 7, 2014
5
0
4,510
0
I recently upgraded my old FX8350 and 990fx motherboard to the ryzen 5 1600 and the gigabyte ga-ab350 gaming 3 motherboard. Everything has been fine for the past two weeks or so, but as I go to turn on my computer this morning, I press the power button and nothing happens. I have ruled out the PSU being the problem with the paperclip test, and I have confirmed that it isn't a faulty power switch on the case. I am assuming that the issue lies with one the new components I installed, but any help to test this or fix the problem would be greatly appreciated!
Specs:
Case: coolermaster haf912
Mobo: gigabyte ga-ab350
CPU: ryzen 5 1600
Graphics: sapphire r9 390 nitro
PSU: Thermaltake 650w smart 80plus bronze
Memory: 8gb ballistix sport LT

Worst comes to worst both parts are under warranty
 

kaptainkuftic

Estimable
Jul 26, 2016
1,430
0
2,960
250
The paperclip test on the PSU only tests if the fans work, or so I've heard.

Stupid solution attempt time - flip the power switch on the back of your PSU off and on, then try booting up. Do that a few times, for whatever reason this seems to work for me when I have similar symptoms
 

grimfox

Distinguished
Jun 2, 2009
774
0
19,360
139
Make sure you have the power switch plugged into the motherboard properly. You can try swapping the power and reset switch to see if that makes a difference. How did you verify the power switch was working? Continuity check with a meter?
 

Shektron

Estimable
May 31, 2017
2,090
0
3,660
459
Try to re-tighten all the connections in the computer, or maybe just unplug and re-plug everything - you might have unconsciously plugged something in the wrong place, especially the power button connector. Also, short the two pins that are supposed to house the power button and see if that works.
 

ASK THE COMMUNITY