Question NTFS Hard Drive changed to RAW

Jun 15, 2022
3
0
10
0
I'm running Windows 10 and have an external USB HDD (Two 2TB disks on RAID 1).
I have had some issues with it being recognized as RAW after I switched back to Windows from Linux but after a few reboots it was fine. Now it is an issue again and not going away.
I can still boot into Linux from a USB (so that's an option if needed to troubleshoot) but the drive would not mount on Linux either. I didn't troubleshoot it further on Linux after that.

When I run chkdsk in Windows I get the following output:

Code:
The type of the file system is NTFS.
Access is denied.

Volume label is nb_external_ntfs.

WARNING!  /F parameter not specified.
Running CHKDSK in read-only mode.

Stage 1: Examining basic file system structure ...
Progress: 0 of 4608 done; Stage:  0%; Total:  0%; ETA:   0:00:15   
Progress: 4608 of 4608 done; Stage: 100%; Total: 30%; ETA:   0:00:11 . 
                                                                                      
                                                                                      
  4608 file records processed.                                                       

File verification completed.
 Phase duration (File record verification): 100.18 milliseconds.
Progress: 0 of 0 done; Stage: 99%; Total: 32%; ETA:   0:00:11 ..
                                                                                      
                                                                                      
  0 large file records processed.                                   

 Phase duration (Orphan file record recovery): 0.03 milliseconds.
Progress: 0 of 0 done; Stage: 99%; Total: 32%; ETA:   0:00:11 ...
                                                                                      
                                                                                      
  0 bad file records processed.                                     

 Phase duration (Bad file record checking): 0.03 milliseconds.
Flags for file record segment 5 are incorrect.
Flags for file record segment 5 are incorrect.

Stage 2: Examining file name linkage ...
Incorrect information was detected in file record segment 5.
Progress: 4704 of 5092 done; Stage: 92%; Total: 80%; ETA:   0:00:03   
Progress: 5092 of 5092 done; Stage: 100%; Total: 91%; ETA:   0:00:01 . 
                                                                                      
                                                                                      
  5092 index entries processed.                                                       

Index verification completed.
 Phase duration (Index verification): 777.27 milliseconds.

Errors found.  CHKDSK cannot continue in read-only mode.
Any ideas on how I can recover the data here without reformatting?
Thank you.
 
Jun 15, 2022
3
0
10
0
I hadn't switched back to Linux since the hard drive started working again. Also, my external enclosure came with RAID support so I'm not using software RAID.

EDIT: I tried using Recuva but a lot of the .txt files (which are the most important part for me) are coming back with nonsense characters, and there are many files I'm not seeing at all. It's also a pain that it recovers every file into a single directory although I could deal with that if at least it brought back all the files.
 
Last edited:
Jun 15, 2022
3
0
10
0
"Flags for file record segment 5 are incorrect."

File #5 is the root directory. There is some fundamental problem here.

You could try the free version of DMDE:

https://dmde.com/
Thank you for the suggestion. I tried running a full scan and I got "WinError 2: The system cannot find the file specified"
If there are options to have this done professionally I wouldn't mind spending money on the recovery. Or if there is just more professional software/methods that such professionals would use I'm ok with doing it myself if anyone could point me to some good resources on the subject.
 
Professional data recovery tools include UFS Explorer, R-Studio, ReclaiMe.

RAISE is an inexpensive tool produced by the same people as UFS Explorer. UFS Explorer is currently regarded as the gold standard in data recovery.
 

ASK THE COMMUNITY

TRENDING THREADS