NTFS volume borked - MFT intact, files not opening in Windows


Feb 8, 2012

So, I made the foolish mistake of attempting to expand the DATA partition on a drive I once had an OS on, and have been using exclusively for storage lately. Using GParted, I tried to expand the 1.36 TB NTFS volume to absorb the 20 gigs at he beginning of the disk, and it corrupted the drive.

I ran chkdsk /f (from recovery console command line) and then chkdsk /r (within windows after a reboot) and I got the file/folder structure back, but every file I clicked on was unresponsive - I just got the (you do not have the proper viewer message for pictures, or VLC opens but cannot play the track, or whatever.)

SO, I tried PhotoRec, running it in Windows briefly, and it was able to recover like 1700 files before I stopped it (I didn't have enough space on any volume to continue to the end.)

Now when I go into the original NTFS volume in explorer, the same pictures it recovered in PhotoRec are displayed properly from the original disk as well, almost like photorec "pointed" the file references to the correct data and the system was able to "remember" where they were at that point...

My question is - where do I go from here? I ordered another 1.5 TB drive and my plan is to set them both up in a Win7 system and run PhotoRec and/or TestDisk on the drive to completition - my hope is that it wil at least recover the photos from the old drive, and that posibly it will "restore" the files like it seems to have done in my initial test.

Anyone have any other non-destructive suggestions about recovering NTFS volumes? it seems like all the files are there, they're just referenced incorrectly or something. The pictures I mostly have backups of anyhow, but there's 300+ gigs of music and 400+ gigs of movies and tv shows on there I'd rather not lose...