• Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Question ntoskrnl.exe missing or corrupt, new install on a clean drive (NVME only) Or clone drive

Jul 2, 2019
7
0
10
0
I recently got error 0xc0000185 with windows 10 on nvme ssd with ntosknrl.exe missing error.
The problem is the ssd nvme works fine before, even though right now on different system.
After multiple trials, I go back setup windows 10 on SATA ssd and everything works fine, not a bug, and I cloned that SATA ssd to nvme, the problem is still there.
I did format, delete Nvme multiple times and tried to use installation usb to fix the error but no success.
Even though I have setup many PCs before and know well to install clean windows but I still don’t know how to fix this.
Please help.
 

Colif

Win 10 Master
Moderator
The problem is the ssd nvme works fine before, even though right now on different system.
I don't understand this, did you move install from another PC?

windows cannot run without ntoskrnl, its the main process of windows.

Have you run memtest on ram?
Try running memtest86 on each of your ram sticks, one stick at a time, up to 4 passes. Only error count you want is 0, any higher could be cause of the BSOD. Remove/replace ram sticks with errors.

(I know you replied to an older thread, I just don't remember what I suggested already)
 
Jul 2, 2019
7
0
10
0
I don't understand this, did you move install from another PC?

windows cannot run without ntoskrnl, its the main process of windows.

Have you run memtest on ram?
Try running memtest86 on each of your ram sticks, one stick at a time, up to 4 passes. Only error count you want is 0, any higher could be cause of the BSOD. Remove/replace ram sticks with errors.

(I know you replied to an older thread, I just don't remember what I suggested already)
hi, that ssd nvme has workes with the system before, noproblem, now, i upgraded RAMs and cannot get into windows, when i tried to format the nvme ssd, and install windows 10, it always gets stucked with the error i have described above.
but the system works with SATA ssd. with sata SSD, i have no problem to install and run windows at all. After using SATA ssd to install windows 10 successfully, i clone the Sata ssd to nvme, and the error is still be the same.
no idea how to fix it.
 
Jul 2, 2019
7
0
10
0
upgraded ram... what motherboard do you have? Is ram on its qvl list?

its possible, if nvme worked fine before, that the new ram is the cause of bsod

Did you run memtest?

hi,
i have gigabyte md71-hbo.
the memtest said all passed.
it worked before with old ram, now, with new ram, it doesnt work with nvme but with ssd sata.
 
Jul 2, 2019
7
0
10
0
hi, i did check with another nvme, it works fine, dont know what causes the problem.
but i think the topic should be closed now.
thanks so much for the help
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts