nV release 56.64 Forceware drivers on THEIR site

No this is not an ASUS/XFX/BFG/etc release, it's direct from nV release before those other sites.

nV skipped the 56.55 and 56.56 drivers due to the issues with UT2K4, and went straight on to the 56.64 drivers.

Here's the link to the XP/W2K ones;

<A HREF="http://www.nvidia.com/object/winxp_2k_56.64" target="_new">http://www.nvidia.com/object/winxp_2k_56.64</A>


- You need a licence to buy a gun, but they'll sell anyone a stamp <i>(or internet account)</i> ! - <font color=green>RED </font color=green> <font color=red> GREEN</font color=red> GA to SK :evil:
 

GeneticWeapon

Splendid
Jan 13, 2003
5,795
0
25,780
They have Fcking cheats in them.

<A HREF="http://rmitz.org/AYB3.swf" target="_new">All your base are belong to us.</A>
<A HREF="http://service.futuremark.com/compare?2k3=2216718" target="_new"><b>3DMark03</b></A>
 
HEhe! :evil:

Not sure if you're kidding or not, but if you look at [H]'s review of the 56.56 drivers, they do force Pixel Shader 1.1 instead of PS2.0 for FarCry (thus take any benchie with a big grain of salt). I wonder if these also have that 'feature' built into them, as they are supposed to be similar but for the UT2K4 tweak.

I'm not a fan of the replacement, but if reviewers know about it and show the diff. like [H] did, then I wouldn't call it a cheat so much as the reality we've come to expect under the FX's poor PixelShader power.

BTW, let the FarCry Demo situation be an example to anyone who thinks the Forware drivers' run-time compiler has FIXED the problem the FXs have.

Funny considering this is a "TheWayIt'sMeantToBePlayed" game, and they obviously had enough lead time to do something other than bump down the shaders. Guess it needs MORE than one driver release to fix these sorts of problems.


- You need a licence to buy a gun, but they'll sell anyone a stamp <i>(or internet account)</i> ! - <font color=green>RED </font color=green> <font color=red> GREEN</font color=red> GA to SK :evil:
 

GeneticWeapon

Splendid
Jan 13, 2003
5,795
0
25,780
It's actually not the nVidia driver forcing ps 1.1 in Far Cry, but the game itself. Far Cry treat's all FX card's as DX8 only, because the card's cannot handle ps 2.0 :wink:

<A HREF="http://rmitz.org/AYB3.swf" target="_new">All your base are belong to us.</A>
<A HREF="http://service.futuremark.com/compare?2k3=2216718" target="_new"><b>3DMark03</b></A>
 

rumcooler

Distinguished
Feb 5, 2003
137
0
18,680
I am so sick of this crap! I think it's time to buy a 9800 pro. Yeah they have new cards coming out soon, but the 9800 pro seems to be a kick ass product right now especially for 200.00. When is nvidia going to learn. They talk about this great product that supports dx9 and pixel shader 2.0 and the cards don't even use it. Why bother! Sorry guys just getting frustrated. All I know is when I get my card I will have a lot of support here.
 
Ok, [H] couldn't seem to tell which it was, it seems strange that it would be the game overriding the choice of PS2.0 by the player.

If it's the game then one would think it could be forced to run PS2.0, or else it will never be available for the FX series (unless they use a technique to fool it into thinking it's another card).

So which were you talking about? Precision or Sarcasm? :wink:


- You need a licence to buy a gun, but they'll sell anyone a stamp <i>(or internet account)</i> ! - <font color=green>RED </font color=green> <font color=red> GREEN</font color=red> GA to SK :evil:
 

kinney

Distinguished
Sep 24, 2001
2,262
17
19,785
I REALLY like these drivers. There are supposedly a bunch of performance increases, but I dont really benchmark so I dont care or notice..
These are very full featured, I'm diggin the multimonitor stuff and desktop features.
You can dig forever in this driver!!!

I'd recommend these to anyone with a NV card. The popup blocker isnt actually that big of a deal in the driver and I had to dig a bit to find it.
Its really awesome to think that the Forceware and its features work on all cards back to the TNT1!
Time to setup some game profiles :smile:

Heres the <A HREF="http://www.nvidia.com/object/IO_11793.html" target="_new">press release</A>.

----
Reject religon, embrace Jesus
Support the terrorists, vote democrat
NV/AMD/IBM axis of evil team leader
RESIDENT FORUM WARRIOR
 
Oh yeah, I agree the features are great. Just like ATI both are finding more benifit from adding additional features than simply trying to boost performance 1% when the cards are near max already.

The features are definitely a reason to upgrade, and the image issues are found in all versions, so not upgrading to the latest set would seem to be stupid for FX owners. I'm surprised as a GF4ti owner that you would find these best as I have heard from most GF4 owners that older drivers offer the best performance. But if you get 90-95% of the performance of those old drivers but with all the new features, it would seem like a great trade-off to me.

The nView features as described by FiringSquad are pretty nice. Same can be achieved through 3rd party software but it's always nice to have things integrated into the software pack (as long as they don't mess other stuff up, which they don't).

Unless someone has specific problems with the 56.64 I'd say it's the best choice for everyone. However I would recommend people avoid the 56.55/56 if they plan on playing UT2K4.


- You need a licence to buy a gun, but they'll sell anyone a stamp <i>(or internet account)</i> ! - <font color=green>RED </font color=green> <font color=red> GREEN</font color=red> GA to SK :evil:
 

TheRod

Distinguished
Aug 2, 2002
2,031
0
19,780
Is the nView features sdhould ba accessible with all the nVidia GeForce?

Because, on my laptop, I have a GeForce GO and I can't find the popup blocker options nor the "screen area divisions/area" for apps. in the nVidia control panel.

Anyone can help me with that?

--
Would you buy a GPS enabled soap bar?
 

kinney

Distinguished
Sep 24, 2001
2,262
17
19,785
I'm surprised as a GF4ti owner that you would find these best as I have heard from most GF4 owners that older drivers offer the best performance. But if you get 90-95% of the performance of those old drivers but with all the new features, it would seem like a great trade-off to me.
Ya I dont care about maximum performance. I mean is the difference that much anyway? Doubt it. Going back will boost your 3dmark or something meaningless like that.
Unless Im uniformed here, but I never recall reading anything that struck me as substantial.
Kinda a nit-picky nerd thing if you ask me.
I'd rather see stability/compatibility fixes (the main reason I use NV in the first place) as primary concern of mine in releases and features second with performance being of equal importance I suppose.
The IQ sacrifices are in every products drivers so that just doesnt get to me.

----
Reject religon, embrace Jesus
Support the terrorists, vote democrat
NV/AMD/IBM axis of evil team leader
RESIDENT FORUM WARRIOR
 

kinney

Distinguished
Sep 24, 2001
2,262
17
19,785
Yeah go to desktop management, click enable then, go down to applications, then click on enhancements and it will be in there.

Theres just so many options and so much stuff in these drivers that sometimes its like wading thru... but man am I loving it!

----
Reject religon, embrace Jesus
Support the terrorists, vote democrat
NV/AMD/IBM axis of evil team leader
RESIDENT FORUM WARRIOR
 

TheRod

Distinguished
Aug 2, 2002
2,031
0
19,780
Humm.... Sorry, but I can't find it.
When you talk about desktop management??? You mean the "nView config TAB desktop"???

--
Would you buy a GPS enabled soap bar?