Info NVIDIA’s "Kepler" GeForce 700 & 600 GPUs receive new security Vulnerability driver.

Hi,

Just some heads-up for those rocking OLD GPU series from NVIDIA. It appears that NVIDIA has recently updated the drivers for KEPLER generation graphics cards and closed some severe security loopholes to prevent hacking. So if you own a Kepler microarchitecture GPU, then you must install this driver update.

FWIW, I have a fully working GTX 660 Ti installed on one of my work systems. For gaming, I only use my RX 480 GPU though. But the GTX 660 Ti can still play less graphic demanding games on 1080p.

For owners of very old graphics cards based on Kepler GPUs, NVIDIA released two new drivers this week that fix serious security vulnerabilities that could be used to hack a computer.

The GeForce 474.04 for Windows 10 and Windows 11 and GeForce 474.06 for Windows 7, Windows 8 and Windows 8.1 drivers fix buffer vulnerabilities with tags CVE-2022-3602 and CVE-2022-3786. Attackers could exploit these vulnerabilities during X.509 certificate validation by replacing a specially crafted email address that allows them to run code remotely. Both vulnerabilities have a threat status of “high”.

GeForce Security Update Driver GeForce 474.04 WHQL for Windows 10 and Windows 11 and GeForce 474.06 WHQL for Windows 7, Windows 8 and Windows 8.1 is for the following graphics cards:
  • GeForce 600 Series: GeForce GTX 690, GeForce GTX 680, GeForce GTX 670, GeForce GTX 660 Ti, GeForce GTX 660, GeForce GTX 650 Ti BOOST, GeForce GTX 650 Ti, GeForce GTX 650, GeForce GTX 645, GeForce GT 640, GeForce GT 635, GeForce GT 630;
  • GeForce 700 Series: GeForce GTX 780 Ti, GeForce GTX 780, GeForce GTX 770, GeForce GTX 760, GeForce GTX 760 Ti (OEM), GeForce GT 740, GeForce GT 730, GeForce GT 720, GeForce GT 710;
  • GeForce Titan Class: GeForce GTX Titan, GeForce GTX Titan Black, GeForce GTX Titan Z.
NVIDIA had previously promised to keep the Kepler architecture secure until 2024.

Regards, Nick.
 
Reactions: alceryes

ASK THE COMMUNITY

TRENDING THREADS