Question Nvidia 3070 Ti GPU is not powered on

Nov 28, 2021
3
0
10
0
I recently built a new PC with following spec:
CPU: Intel i7-11700k
Motherboard: MSI Z590 Gaming Carbon WiFi
GPU: Nvidia 3070 Ti
Memory: Corsair 8x2 GB
PSU: MSI MPG 850W

when I start the computer, everything is working except GPU. The gpu is supposed to spin for a while and then stop (cause the temp not reach to the limit.). because gpu is powered on, so motherboard is not able to detect it, not mention install drivers, etc. I've tried a new psu, changed slots of PCIe, reset CMOS. Nothing is working. GPU fans are still not spinning when I start up the computer. Any helps? many thanks
 
When you connect to the integrated graphics, does the device manager shows the GPU?

Go into bios and change the pcie gen to 3.0 instead of auto.

Try the GPU in another system afterwards. If all does not show/work then you need to RMA the GPU
 
Nov 28, 2021
3
0
10
0
When you connect to the integrated graphics, does the device manager shows the GPU?

Go into bios and change the pcie gen to 3.0 instead of auto.

Try the GPU in another system afterwards. If all does not show/work then you need to RMA the GPU
Thank you for your reply. Unfortunately, no gpu shows up in device manager, but only the integrated gpu. Cause I only have one desktop, so not able to test it in another system. And my gpu is bought from my friend who is working in Nvidia, so I don’t think the gpu is faulty. But I will try the bios. Thanks!
 
Nov 28, 2021
3
0
10
0
Whats the complete brand and model of the GPU?

Are you using independent 6+2 PCIe cables for the GPU?, How many?, don't use daisy chain cable on it.
My gpu is Nvidia 3070 Ti. PSU is MSI MPG 850. Yes, I connected psu with gpu using two separate PCIe cables, no daisy chain cables at all.
 

ASK THE COMMUNITY

Latest posts