Nvidia driver support question (I've done most of it following a guide, quick question)

Matthew Mendez

Reputable
Jun 29, 2014
50
0
4,640
1
SOLUTION: Try turning off "Digital NR" in your monitor settings. I'm using a Samsung TV as a monitor and I had the issue when it was set to "auto". My problem doesn't seem to be 100% solved, but I would say this fixed like 90% of it, maybe I'm just being picky.

I'm trying to fix a problem with my drivers, and I was directed to this guide (https://rhymeswithtoaster.com/2013/12/22/how-to-fix-nvidia-blurry-or-fuzzy-screen-or-text-caused-by-driver-installation/). I've gotten to part 4 of 5, but I don't know where to put the line. The guide is a few years old so it's a little different now I'm guessing.

I found nv_dispi.inf at C:\NVIDIA\DisplayDriver\376.33\Win10_64\International\Display.Driver

My monitors EDID is 4C,2D,0D,05 and following the guides scheme the line should be HKR,,OverrideEdidFlags0,%REG_BINARY%,4C,2D,0D,05,00,00,FF,FF,04,00,00,00,7E,01,00

Can anyone confirm this is correct and direct me to where I should put the line? This is for driver version 376.33 (the current version). Thanks for any assistance.
 

Matthew Mendez

Reputable
Jun 29, 2014
50
0
4,640
1
SOLUTION: Try turning off "Digital NR" in your monitor settings. I'm using a Samsung TV as a monitor and I had the issue when it was set to "auto". My problem doesn't seem to be 100% solved, but I would say this fixed like 90% of it, maybe I'm just being picky.
 

Eximo

Titan
Ambassador
I would give this a try as installing unsigned/untrusted drivers can require some extra steps. I think the article was written for older OS.

-----------------

great thanks. Totally working for me, article written in 2013, still working in 2016.
Just that important steps if using windows 8.1, must disable driver signature check.
(like going to safe mode. press shift then click restart, go to advance and your options is there)

Also, instead of using phoenix (which doesn’t work for me), just use regedit, go here:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY

the 1st 8 bytes of the edid will be 00,ff,ff,ff,ff,ff,ff,00
2nd 8 bytes will be (for me): 1d,6b,34,32,01,00,00,00
take 1d,6b,34,32, replace with xx,xx,xx,xx above.

the inf located here:
NVIDIA\DisplayDriver\368.81\Win8_Win7_64\International\Display.Driver
I modify 2 inf:
nv_desktop_ref4i.inf
nv_dispi.inf

add the HKR,,OverrideEdidFlags0,%REG_BINARY%,1D,6B,34,32,00,00,FF,FF,04,00,00,00,7E,01,00
on the follwoing:
[nv_commonBase_addreg]

reboot to the disable driver signature check
install the setup.exe
it’ll prompt warning because you modify the inf, ignore, install, and tada. I have crisped text on my TV

Note that I connect my pc through DVI-HDMI to my TV.
Previously it was detected as HDMI on the nvidia control panel, and the text is blurry.
after the hack above, it is detected as DVI and the text is sharp.
 

Matthew Mendez

Reputable
Jun 29, 2014
50
0
4,640
1


After doing this I was able to get the edited driver to install, but it did not fix my problem (stuff is still grainy). There is no [nv_commonBase_addreg] in either file, only [nv_commonBase_addreg_0X] with X being 1-4 in nv_dispi.inf and 1-2 in nv_desktop_ref4i.inf

I added the line to 1-2 in both files. Do you think adding the line to 3-4 would make any difference?
 

Eximo

Titan
Ambassador
Not really sure, as I have not heard of this problem until now. With each driver release, you never know what will still work.

You could try using older drivers with this fix. Depends how much time you want to spend on it.

Does the same issue occur with other monitors or connection types?
 

Matthew Mendez

Reputable
Jun 29, 2014
50
0
4,640
1


I tried using a different HDMI cable and a VGA, and got the same result, so it's got to be either the drivers/desktop or the monitor. I've spent all day working on this so I guess I'm ready to just call over Geek Squad or something lol hopefully they can fix it. Thank you for your help.
 

Eximo

Titan
Ambassador
I hate to rag on Geek Squad, but the level of expertise they have probably isn't up to this task either. (Oddly a good percentage of the people I work with are former Geek Squad though, the good ones don't tend to stick around and put up with big box store policies)

What they can do though is try out other hardware and see if the problem disappears.

That is also does it over VGA is disturbing since that is analog. I'm not sure if contemporary drivers even deal with VGA other then needing to know the output resolution and frequency.

Does the On Screen Display of the monitor also look blurry?
 

Matthew Mendez

Reputable
Jun 29, 2014
50
0
4,640
1


Geek Squads solution is usually just to reinstall Windows, definitely not the most helpful lol

The problem actually seems to go away with VGA, but the overall quality isn't as good.

I don't think the monitor settings has the issue, but it's difficult to tell on a static image. It's only really noticeable with movement.
 

Matthew Mendez

Reputable
Jun 29, 2014
50
0
4,640
1


Under "Picture" it has Modes -> Dynamic, Standard, Natural or Movie.

Then, Picture Options -> has options like Color Tone, Size, Digital NR, HDMI Black Level and Auto Motion Plus 120Hz.

Respectively, I have it set to Normal, Screen Fit, Auto, Normal and Standard.

I've fiddled with the options a bit and nothing seems to fix it.

I don't see an option to change the frame rate, but it says 1920x1080 @60Hz whenever I turn it on.
 

Matthew Mendez

Reputable
Jun 29, 2014
50
0
4,640
1
SOLUTION: Try turning off "Digital NR" in your monitor settings. I'm using a Samsung TV as a monitor and I had the issue when it was set to "auto". My problem doesn't seem to be 100% solved, but I would say this fixed like 90% of it, maybe I'm just being picky.
 

ASK THE COMMUNITY