Question Nvidia driver uninstalled itself, can't re-install, GPU not showing in device manager

Dec 12, 2019
2
0
10
0
ROG Strix G531GU, Win 10 Home ver 1909, i5-9300H 1660ti DDR4 16GB

What happened before this problem occurred, put the laptop to sleep then went to work, came back to this problem.

As the title mentioned, when I try to install the driver with GFE and standalone installer, it says the driver not compatible with this version of windows. Device manager not showing my dedicated GPU, even in safe mode. Nvidia Drivers tried are 441.87, 442.19 - WHQL, GPU from the ROG website.

Device manager only shows Intel iGPU under display, there is however other devices with 2 unknown devices under it.

What I have tried:
  1. Tried the newest driver or the one that was installed before, same result.
  2. DDU in safe mode, restart, then install the driver, same result.
  3. Update windows, it downloaded and then the update couldn't even install.
  4. Reset windows.
What I know I can't do to solve this is, system restore, as I have tried this before and accidentally wipe the restore point I created a few weeks back.

Please help, I'm at my wits end!
 
Last edited:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Can you go into BIOS and see which version you're currently working with? If you have a BIOS update pending, update to the latest and then retry installing the drivers.

I'm assuming you downloaded the Game Ready Drivers(GRD) from Nvidia's support site?

Laptop is yet under warranty period? You could backup all your critical content from the OS's installation drive(onto a removable storage device) and reinstall the OS.
 
Dec 12, 2019
2
0
10
0
Welcome to the forums, newcomer!

Can you go into BIOS and see which version you're currently working with? If you have a BIOS update pending, update to the latest and then retry installing the drivers.

I'm assuming you downloaded the Game Ready Drivers(GRD) from Nvidia's support site?

Laptop is yet under warranty period? You could backup all your critical content from the OS's installation drive(onto a removable storage device) and reinstall the OS.
Not sure how to get into BIOS, however if there is an update due, the ROG software would show it, so I guess there isnt.

Yes, i did download GRD from the site, also the driver from the ROG website.

Yes, the laptop is still under warranty period. I did already reset the windows, still not working.

There is however other devices tab in device manager and there are 2 unknown devices with ! mark on them.
 

ASK THE COMMUNITY

TRENDING THREADS