Question Nvidia Geforce 1070ti - code 43 and SLI not working when M.2 connected

Jan 21, 2020
Hi all,

I've got an issue with my PC that I'm hoping you can help me resolve.
I've recently bought an NVMe M.2 Corsair Force Series MP600 and installed it. The drive works fine, however my dual graphics system has stopped working.
One of the graphics cards seems to be working just fine, but the other one is reporting an error code 43, and as a result my SLI is not working either obviously XD

Here are my specs:
Motherboard: ASUS ROG STRIX X470-f GAMING

CPU: AMD Ryzen 7 2700X

Graphics: 2x Nvidia Geforce 1070ti Cerberus

RAM: HyperX 16GB KIT 3200 MHz DDR4

Drive in question: M.2 Corsair Force Series MP600 (I also have 2 SSDs and 1 HDD connected to SATA ports)

PSU: Seasonic Focus Plus 850 Gold

I've tried updating the graphics drivers and removing the battery from the motherboard.
When I remove the M.2, the graphics works fine just as before.


EDIT as I'm trying different things: I tried connecting only one GPU, code 43 when connected to PCIex16_2 slot, otherwise works fine (in slot PCIex16_1) The processor allows for 20 lanes (16x in first slot or 2x8), so it makes sense (+ 4x for M.2).
Updated BIOS to latest version
Last edited: