Nvidia GeForce GT525M - Not working all what ive tried inside

Askwil

Distinguished
Oct 23, 2011
37
0
18,530
Hi just finished a deep virus clean, dont know if this would affect my GFX but here is the steps ive taken to get this card to work!! I was able to play Crysis 2, GTA4, F1 2020 etc before this happened with great frame rates but now all games run on the intel card and not my GT525M!

My laptop is a Dell XPS L502X

I have a GPU monitor widget on my desktop, it is always displaying a temperature of around 50C but the FAN, GPU Load and VRAM used graphs remain constantly empty even if i try to run a game such as Crysis 2. (Although with it being a laptop GPU it may not have its own fan but the other 2 i am clueless)

1. Re-Installed Latest Drivers
2. Installed Latest BETA Drivers
3. Installed original Dell Drivers
4. Uninstalled Drivers, Ran Nvidia Driver Cleanup in safe mode, Reinstalled Latest Drivers (SOME PROGGRESS - When i rebooted i have half GPU Load and Full VRAM used, it was for no apparant reason and eventually just dropped to nothing again, when i opened a game it spiked a few times but the game did not use the GPU)
5. Repeated last step but tried installing BETA drivers instead, did not get anyything other than the Temp here.

Away from the driver ive:
1. Opened Nvidia control panel and set global settings to run High end Nvidia graphics (not Intel)
2. Set the actual process itself of every game to run with Nvidia card with no luck.



I am vastly running out of ideas and would appreciate any help it just happened out of nowhere and ive only had this laptop 2 months!

Thanks a lot i hope to get a reply the Nvidia and Dell forums are like ghostowns but i know when ive posted here in the past ive got some good replies!

Thanks a lot! :(
 
Check your energy settings and make sure that it is not underclocking the card.

Also check and disable the energy saving feature of the gpu on nvidia's graphics card program.

Get gpu-z and get gpu detail from there.
 

Askwil

Distinguished
Oct 23, 2011
37
0
18,530
Hi there I have set my laptops energy profile to high performance, so higher performance but lower battery life!

How do i disable to energy saving feature? If i open nvidia control panel i cant find that option i have 3D settings, Display and Video and i cant find that anywhere.

here is GPUz
fqd.png


I have no idea what GPUz is telling me about the card im not so good at this!

Thanks for the reply
 
everything looks fine from gpu-z

So did you have game quality settings set to high on the nvidia program?

Try lower that. I suspect that overrides your game setting and running games on high will definitely slow down your card.

Not sure about nvidia, but for amd cards, there is a check box for AA etc that you can tick and select let program decide so game quality settings is not override.
 

Askwil

Distinguished
Oct 23, 2011
37
0
18,530
Ok well i cant edit that in the control panel?

All i can do is edit either the global setting ot always use Intel or Nvidia card and i can edit indivudual processes to use cartain ones, ive set games ot use the nvidia both globally and individually with no luck?

Anyway of testing the GPU somehow to make sure its just not dead?

Thanks
 

Askwil

Distinguished
Oct 23, 2011
37
0
18,530
Just to let you know games are running in Intel graphics i cannot get themt o run on the Nvidia, in GTA4 it says i have 59MB total VRAM and its completely unplayable.

Also i ran Real-Time HDRibl and it was only letting me use the Intel on that test and wouldnt let me run it with the Nvidia
 
gpu-z picked it up and the frequency is fine on the gpu.

No, there isn't a program to manage the gpu for nvidia card? Alright, I haven't had a nvidia card for ages, but there should be one because when I help people on this forum with nvidia card, they always seem to be able to find it.
 

Askwil

Distinguished
Oct 23, 2011
37
0
18,530
I have posted in the dell forum, no reply seems to be pretty dead ive Just done a full uninstall of everything Nvidia then safe mode, Driver cleaner pro for Nvidia drivers and installed Dell drivers, no change

As for the nvidia settings all i have is the Nvidia control panel?
 

Askwil

Distinguished
Oct 23, 2011
37
0
18,530
I bought my laptop from ebay, i rang the support today and they said its not in my name if i had name of original purchaser i can use warranty, so i asked ebay seller to find out and he says he gets them from a few different companies, could be ages before i can find out who got it so i can use the technical support :/

So unhappy :(
 

Askwil

Distinguished
Oct 23, 2011
37
0
18,530
No was bought brand new and sealed from a company from ebay, thay said they got the stock from 3 other companies but said it will be hard ot find who they are registered to.

He said i can send it to him, he can get it sent off to dell but i dont want to just send him the laptop with no contract or anything saying he cant just keep the thing!
 
Do you have a receipt?

I mean, if you buy it on ebay, it is a shop right. Then as long as there is a receipt, you have proof of purchase and not stolen and DELL has to give you tech support.

Man, when I get my ASUS laptop returned for a new HDD, they didn't even ask me for a receipt. They just arrange a courier to pick it up from my door the next morning.

 

Askwil

Distinguished
Oct 23, 2011
37
0
18,530
Lol lucky for you, they sai don the support line i need the name or addres or invoice of the original purchase!


If i cant get hold of it i will have to contact customer services, surely it is wrong to refuse service when i have the laptop here and i have the item bought on my ebay accoount!!
 
Well, DELL support for you. They are terrible I heard. I had a DELL before, but luckily, I don't have to use their support service and the machine don't have any problem until its 6th year.

DELL 0: ASUS 1