[SOLVED] NVIDIA GeForce GT620 & SAMSUNG 40" LED TV

Jan 28, 2020
26
1
45
1
I have an ASUS Essentio Desktop running the factory NVIDIA GeForce GT 620 graphics card. I have it connected to a Samsung J5200 Series 40" 1080p HD LED TV. I am having problems with image quality and resolution. Even though the TV is 1080p HD (1920 x 1080) and the NVIDIA GeForce GT 620 card supports resolutions up to 2560 x 1600, when I set my resolution to 1920 x 1080 the desktop is stretched beyond the screen of the TV, to get it to fit within the full screen I have to custom set it to 1842 x 1026. Even @ 1842 x 1026 (highest resolution I can achieve), text is blurry and image is not clear. I can also set the resolution to 1768 x 992 but thats even worse.

Would upgrading the graphics card to say a MSI Radeon RX 580 DirectX 12 make any difference? I want to run a full 1080p HD resolution on my TV.
This is the card I was looking at: https://www.newegg.com/msi-radeon-rx-580-rx-580-armor-8g-oc/p/N82E16814137118

Heres the specs on my system:
-Intel i5-3470 H77 Chipset @ 3.20GHz
-16GB DDR3
-Windows 7 Professional SP1 (64 Bit)
-NVIDIA GeForce GT 620 (Running Latest Version of the NVIDIA Drivers)
-SAMSUNG UN40J5200AF 40" 1080p LED

Thanks guys,

-Ian
 
Last edited:
Jan 28, 2020
26
1
45
1
I finally got it!
-Set graphics card and OS resolution output to 1920 x 1080 (1080p)
-Disabled "Desktop Resizing and Position" in NVIDIA control panel
-Used remote for my SAMSUNG TV to go to "Menu" > "Picture" > "Picture Size" > "Screen Fit"

Works perfectly, thanks for all your help guys.
 
Jan 28, 2020
26
1
45
1
I have an ASUS Essentio Desktop running the factory NVIDIA GeForce GT 620 graphics card. I have it connected to a Samsung J5200 Series 40" 1080p HD LED TV. I am having problems with image quality and resolution. Even though the TV is 1080p HD (1920 x 1080) and the NVIDIA GeForce GT 620 card supports resolutions up to 2560 x 1600, when I set my resolution to 1920 x 1080 the desktop is stretched beyond the screen of the TV, to get it to fit within the full screen I have to custom set it to 1842 x 1026. Even @ 1842 x 1026 (highest resolution I can achieve), text is blurry and image is not clear. I can also set the resolution to 1768 x 992 but thats even worse.

Would upgrading the graphics card to say a MSI Radeon RX 580 DirectX 12 make any difference? I want to run a full 1080p HD resolution on my TV.
This is the card I was looking at: https://www.newegg.com/msi-radeon-rx-580-rx-580-armor-8g-oc/p/N82E16814137118

Heres the specs on my system:
-Intel i5-3470 H77 Chipset @ 3.20GHz
-16GB DDR3
-Windows 7 Professional SP1 (64 Bit)
-NVIDIA GeForce GT 620 (Running Latest Version of the NVIDIA Drivers)
-SAMSUNG UN40J5200AF 40" 1080p LED

Thanks guys,

-Ian
 
Last edited:
Some things try
  • Look for a "game mode" on the TV.
  • Does the TV have zoom settings like full screen, 4:3, cinema, zoom 1, zoom 2?
  • Can you categorize/ define inputs on the TV? If so, set this input to "PC/Computer/etc"
 
Jan 28, 2020
26
1
45
1
Some things try
  • Look for a "game mode" on the TV.
  • Does the TV have zoom settings like full screen, 4:3, cinema, zoom 1, zoom 2?
  • Can you categorize/ define inputs on the TV? If so, set this input to "PC/Computer/etc"
All great ideas, I have to grab the matching remote to the TV, as soon as I get it I will try those things, right now I'm stuck using the only single power button on the TV to navigate.

Thanks!
 
Check the overscan/underscan settings in nVidia Control Panel before running out and buying a new GPU. Also check the picture settings on the TV. As it may be doing an overscan (stretch, widescreen, zoom, &c). Typically those problems with TVs and computers are either a TV setting or computer settings.

Also, even with the resolution fixed. Turn off any image enhancements on the PC input. Something like motion enchancement, noise filter, contrast boost and so forth. Any sort of automatic enhancement. As they typically are horrible with a computer. Frankly, they are bad all around. Producing the soap opera affect. Which people have become used to.
 
Jan 28, 2020
26
1
45
1
Checked settings on tv and nvidia control panel, no special settings enabled, tv is set to 16:9 standard. Does the general image/display quality usually change with hardware upgrades like a new gpu? As I understand its mainly the OS and resolution that determine that (aside from settings and display quality or specs). From what ive read TVs have a display designed for more distant viewing so thats probly my problem, still would like to get it at the optimal 1080 resolution though, that would probably at least help the lack of clarity.
 
Last edited:
Jan 28, 2020
26
1
45
1
I tried enabling "game mode" and tried the different display settings like "Zoom" & "Standard", nothing works. Also tried assigning inputs but theres no option for that. I still cant get the 1920 x 1080 resolution to fit the TV screen.
 
Jan 28, 2020
26
1
45
1
I can resize to 1824 x 1026 to make it fit but I cant get a 1900 x 1080 resolution. I need to get a 1080p resolution to fit to get the clarity and detail.
 

Zizo007

Notable
Feb 23, 2019
1,372
170
940
34
I can resize to 1824 x 1026 to make it fit but I cant get a 1900 x 1080 resolution. I need to get a 1080p resolution to fit to get the clarity and detail.
Don't change the resolution, keep it at 1080p.
With AMD you can resize the desktop without affecting the resolution.

In nvidia control panel do you have the scaling mode option?
If yes, select Full Screen.
 
Jan 28, 2020
26
1
45
1
I used to have a 32" Samsung LCD HD TV as my monitor on this PC and it had similar display problems. My motherboard has integrated graphics but no HDMI output so I can't try this 40" LED TV with integrated graphics (TV doesn't have a VGA or "PC" input. I have tried resizing and scaling to no prevail.
 
Jan 28, 2020
26
1
45
1
I am thinking it is a problem related to my specific graphics card, the GeForce GT 620. I can set the resolution to 1080p but it goes over the edges on the display, resizing doesn't change resolution it just resizes it.
 
Jan 28, 2020
26
1
45
1
I finally got it!
-Set graphics card and OS resolution output to 1920 x 1080 (1080p)
-Disabled "Desktop Resizing and Position" in NVIDIA control panel
-Used remote for my SAMSUNG TV to go to "Menu" > "Picture" > "Picture Size" > "Screen Fit"

Works perfectly, thanks for all your help guys.
 
Jan 28, 2020
26
1
45
1
Ultimately I never tried keeping the 1920 x 1080 resolution AND adjusting the TV's picture size settings, I'm not sure why I never tried that, guess I just set the resolution on the PC and saw it going over the edges and assumed something was wrong and that that particular resolution was not going to work.
 
Last edited:
Jan 28, 2020
26
1
45
1
"Screen Fit" Picture Option on my TV was not an available option because of another TV Picture Setting, Changed that, selected "Screen fit" and it worked.
 

ASK THE COMMUNITY

TRENDING THREADS