Question Nvidia Geforce RTX 2080

frank111111

Honorable
Jan 9, 2014
2
0
10,510
0
I had this computer for about 2 years. I have 4 screens ( 3 TV and a 144hz gaming monitor). Everything has been working flawlessly since the beginning.

Yesterday, i rebooted my computer and my gaming monitor would not be detected. Display port no signal. I could see it in windows as a deactivated screen but whenever i would want to activate it the whole computer would freeze ( not just the window) and i would need to shut it down manually. I was shocked because the screen worked 2 minutes ago.I tried an other cable, same thing. I searched the web for info and tried disconnecting power from the screen for 1 minute to reset it and it did not work, I uninstalled and reinstalled video drivers several times with no success. The strange thing is that none of my 4 screens were showing the initial boot to windows. Only when windows came to the log in screen did one screen showed it.

I tried a lot of things ( i don't remember all of them) and eventually i managed to see the boot on my gaming monitor and once it reached windows it deactivated. Now i guess that proves that the problem is not with the cable nor the screen. I had the idea to unplug all the 3 other screens to "force" it to show windows on my monitor and it worked. I can reconnect 1 of the other screen and keep the gaming monitor but as soon as i connect one of the other 2 screens my gaming monitor goes to "no signal" mode. I don't know what to do next.


Here is some of my spec:

Nvidia Geforce Gtx 2080
Windows 10 64 bits
Z370 Gaming Infinite X (MS-B916)
Intel I9-9900K cpu
32G ram
My gaming monitor is a Asus VG248QE

Thank you everyone for the help
 

Lutfij

Titan
Moderator
Which version of Windows 10 are you working with? What is the make and model of your PSU and it's age? Which BIOS version are you working with for your motherboard?

You might want to try and use DDU to uninstall your GPU drivers and manually source the latest drivers from Nvidia's support site. Once downloaded, install the drivers in an elevated command, i.e, Right click installer>Run as Administrator.
 

ASK THE COMMUNITY