[SOLVED] "NVIDIA GPU only" making literally everything stutter

Nov 11, 2021
211
3
585
0
Every single time I enable NVIDIA GPU only from nvidia's control panel, everything starts stuttering. Like ANNOYING STUTTERING! Not just in games too, it's EVERYWHERE! I've seen it in task manager and whilst using fraps, the usage dips or spikes suddenly/the fps dips or spikes suddenly, which causes these ANNOYING stutters!

And the temps aren't even that high. GPU is around 51 Celsius degrees right now. (Having 3 tabs open including 1 yt vid, fraps, nvidia control panel, notepad, taskmanager)

In games I've tried using G-Sync, but it still dips and spikes! But when I enable Optimus, everything is COMPLETELY smooth again (except of course that it's an igp)

Please help. Thanks!

Laptop spec sheet: https://psref.lenovo.com/syspool/Sys/PDF/Legion/Lenovo_Legion_5_15ITH6H/Lenovo_Legion_5_15ITH6H_Spec.pdf

Mine is the 11400H with 3060 130W

Edit: This is what I mean by dips and spikes. And that was only by scrolling up and down on a youtube 1080p vid..


 
Last edited:
Hey there,

What power plan are you using? Change it to high performance by typing the following into powershell:

powercfg -duplicatescheme 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c

By doing it in powershell it will overwrite any changes you may have made but forgotten about in the power plans. See how that goes.

All drivers up to date (chipset etc), GPU. Laptop bios?
 

Ralston18

Titan
Moderator
And also use Resource Monitor to observe system performance.

Determine what system resources are being used, to what extent (%), and what is using any given resource.

Specifically watch for changes that correspond with the stuttering.

Laptop drive(s): make, model, capacity, how full?
 
Nov 11, 2021
211
3
585
0
Sorry for late reply.
Hey there,

What power plan are you using? Change it to high performance by typing the following into powershell:

powercfg -duplicatescheme 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c

By doing it in powershell it will overwrite any changes you may have made but forgotten about in the power plans. See how that goes.
Hey,

If you mean by power plan, this:


I use Quiet mode most of the time, but when gaming I use performance mode. But I'd like to assure you that the stuttering problem is here no matter which mode I choose.

Also I did the powershell thing, it didn't work.



All drivers up to date (chipset etc), GPU. Laptop bios?
GPU is up to date.

Just Updated bios from h1cn47ww to h1cn48ww and the problem is still here.

Unsure about the chipset, how do I check?
And also use Resource Monitor to observe system performance.

Determine what system resources are being used, to what extent (%), and what is using any given resource.

Specifically watch for changes that correspond with the stuttering.

Laptop drive(s): make, model, capacity, how full?
I did use Resource Monitor, no unusual behaviour is going on, and I don't think it has a gpu monitoring section.

Using task manager though, the same exact thing ;-;

The only possible problem I see is in the gpu, I mean it only happens when I turn on "nvidia gpu only".

Look at this..

GPU usage is literal mountains.
The GPU corresponds with the stutters, it dips and spikes. But also disk 0(nvme drive) is corresponding with the gpu. Could it be that maybe it's disk 0's problem?

Laptop drive (disk 0): Model: SAMSUNG MZVL21T0HCLR-00BL2
Capacity: 1024GB (only 976GB's are available)
How full: 97GBs are used
Read and Write speeds:
 
Nov 11, 2021
211
3
585
0
For anyone wondering, I found the problem at last ;-;

The problem was the MUX switch :)

Nvidia control panel's MUX switch aka "nvidia gpu only", possibly sucks. Or maybe it's not even a MUX switch like I understood.. It's just advanced optimusI guess ;-;

Anyways, "hybrid mode" was on in lenovo vantage software. When I turned it off (required a restart) everything became officially ✨buttery smooth✨. IGP wasn't being utilised at all now, wasn't detected in task manager, and in nvidia control panel, the "change display mode" option wasn't there anymore.

So basically Nvidia's advanced optimus sucks, and turning off hybrid mode made everything ACTUALLY ✨buttery smooth✨, finally 😩

And bonus!! It didn't draw more power or whatever, and the temps are literally the same if not lower. (depending on openhardwaremonitor's readings in 3 different games and on idle) Tested while plugged in.

Hope this helps!!
-Paro
 

ASK THE COMMUNITY

TRENDING THREADS