[SOLVED] Nvidia GPU recently clocked down to ~140MHz at full load

Dec 12, 2021
4
1
15
0
Hi, my problem is that my Nvidia Quadro P2000 (Dell Precision 5530 laptop, Intel Core i7-8850H, 32GB RAM, 4GB GPU memory) has recently been clocking down to ~140MHz :eek: at full system load, although the nominal clock is ~1200MHz and boost clock is ~1500MHz.

I was able to play graphically complex games like Battlefield 5, Forza 4, Rise of the Tomb Raider normally/semi-fluidly until a few weeks ago. But now they are unplayable (regardless of quality settings) due to lags (every 1-2s). So I started to analyse the problem and ended up with the following setup to reproduce it reliably (besides said games):
  • GPU load with Unigine Superposition Benchmark
  • CPU load with 7-Zip benchmark
  • GPU clock, GPU temperature, PerfCap Reason, CPU temperature with GPU-Z
I ran the following test scenarios:
  • GPU full load under Windows
    => The GPU constantly runs into PerfCap Reason=Thermal at ~73°C, whereby the clock remains at the nominal clock.
  • GPU+CPU full load under Windows
    => The GPU is constantly clocked down to ~140MHz at ~76°C and 98°C for the CPU because of PerfCap Reason=Thermal.
  • GPU full load under Linux
    => The GPU runs constantly at 85-88°C with ~1300MHz.
  • GPU+CPU full load under Linux
    => The GPU runs constantly at 85-88°C with ~1300MHz. :unsure:
Due to the fact that it used to run better and I can prove with Linux that it is not a hardware problem, I am now looking for a software solution. I have already tried in vain with different energy saving settings, stronger power supply and different driver versions.

Does anyone have a tip on how to prevent this clock reduction?

btw: According to Linux Nvidia driver tool the GPU throttling temperature is 97°C.

Cheers,
Christian
 

JWNoctis

Prominent
Jun 9, 2021
389
85
490
55
  • GPU full load under Windows
    => The GPU constantly runs into PerfCap Reason=Thermal at ~73°C, whereby the clock remains at the nominal clock.
  • GPU+CPU full load under Windows
    => The GPU is constantly clocked down to ~140MHz at ~76°C and 98°C for the CPU because of PerfCap Reason=Thermal.
  • GPU full load under Linux
    => The GPU runs constantly at 85-88°C with ~1300MHz.
  • GPU+CPU full load under Linux
    => The GPU runs constantly at 85-88°C with ~1300MHz. :unsure:
Make sure the CPU is properly loaded at all under your test condition in Linux.

Most laptops share heatpipes and heatsinks between CPU and GPU. My guess: Your GPU is throttling because your CPU is. I don't know the specifics, but it certainly is within the realms of possibility.

Dust your heatsink fins with an air duster or similar. There are guides for that, but do it carefully as you don't want to damage your heatsink fan. See if that helps.
 

JWNoctis

Prominent
Jun 9, 2021
389
85
490
55
  • GPU full load under Windows
    => The GPU constantly runs into PerfCap Reason=Thermal at ~73°C, whereby the clock remains at the nominal clock.
  • GPU+CPU full load under Windows
    => The GPU is constantly clocked down to ~140MHz at ~76°C and 98°C for the CPU because of PerfCap Reason=Thermal.
  • GPU full load under Linux
    => The GPU runs constantly at 85-88°C with ~1300MHz.
  • GPU+CPU full load under Linux
    => The GPU runs constantly at 85-88°C with ~1300MHz. :unsure:
Make sure the CPU is properly loaded at all under your test condition in Linux.

Most laptops share heatpipes and heatsinks between CPU and GPU. My guess: Your GPU is throttling because your CPU is. I don't know the specifics, but it certainly is within the realms of possibility.

Dust your heatsink fins with an air duster or similar. There are guides for that, but do it carefully as you don't want to damage your heatsink fan. See if that helps.
 
Dec 12, 2021
4
1
15
0
After further tests, I noticed that Linux and Windows differ in the prioritisation of throttling.

Under Linux, the CPU and GPU clock speeds remain relatively constant at ~1300MHz (GPU) and ~2600MHz (CPU).
Under Windows, the CPU clock rates change between ~2600MHz and ~3200MHz (TurboBoost), while the GPU clock rate drops into the bottomless as mentioned.

Thus it seems as if Windows prefers to throttle the GPU while Linux "throttles" the CPU (no TurboBoost).

Does anyone know if this prioritisation can be adjusted somehow? Is there a tool that can dynamically control or switch on/off the TurboBoost in Windows?
 

JWNoctis

Prominent
Jun 9, 2021
389
85
490
55
If your applications are not CPU-bound, you can try limiting your processor's maximum performance in Windows' power options to something like 80%. This is in effect a clock frequency cap, and will also effectively disable turboboost.

There might be better ways to do this, but this one is probably the easiest and the most commonly applicable among most laptops. See if that helps.
 
Dec 12, 2021
4
1
15
0
If I switch off Intel Turbo Boost, I also get the same behaviour under Windows as I see under Linux. This means much more stable GPU clock speeds.
I have now installed Throttlestop. With it I can comfortably switch Intel Turbo Boost off/on before/after gaming.

Since most of my games are GPU-limited anyway, the CPU clock limitation has hardly any negative effect.
Not the perfect solution, but good enough. :)
 
Reactions: JWNoctis

ASK THE COMMUNITY